cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
153
Views
0
Helpful
0
Replies
Highlighted
Beginner

DPC3941B port forwarding

I've a client  with a retail store obtaining internet from Comcast Business ISP.  The modem/router provided is the DPC3941B.  I installed a Windows 10 PC hosting VMWare Workstation 15 as a host to a UNIX VM. The problem I have is setting up port forwarding from the public WAN IP to the LAN IP of the UNIX VM.  I have configured a non-standard port 3NN22 for SSH and the port forwarding works during the business hours of the store 11:00 to 17:00.  I can connect via SSH on the non-standard port ok.  But in the evening, SSH will not connect.  This is a problem as the store owner desires to log-in after hours via SSH. I've talked to Comcast business technical support about the issue but have not been able to resolve it.  

 

I set up remote administration on the DPC3941B so that I can try to resolve the issue but the DPC3941B has no diagnostic tools to ping local LAN IP addresses. 

How stupid is that? 

 

One other clue is that when SSH connections are timing out,  I log-in remotely to the DPC 3941B but  I can't add new port forwarding rules:  I tried to temporarily set up telnet on port 23 WAN to UNIX VM LAN IP port 23 but the attempt fails with an error message:  "Alert    Failed to add."

 

 I have not tried to add the port 23 test forwarding rule while the SSH port forwarding is working (during business hours).

 

My last gripe is that I can't SSH from the LAN IP (outgoing) to the public WAN IP of the DPC3941B and have it connect to the UNIX VM.  I can use SSH from the LAN IP to my office WAN IP, connect to my office UNIX server and the SSH to the WAN IP of the DPC 3941B forwarded to the UNIX VM. This became obvious when the owner bought a new Windows 10 PC for use to connect to the store UNIX VM after hours and I set the PC up in the store on tried to make the SSH connection so that we would know it worked before he took the machine home. 

 

I spent 56 minutes on the phone and went over all this with the Comcast support technician while on-site at the client's store and logged in to the DCP3941B from the local LAN  but she was unable to resolve any of these issues.  

 

I have two more identical hardware/software Windows 10 PC hosting VMWare Workstation 15 and UNIX VM's at other clients (not Comcast ISP)  that work without this "outside business hours" access problem. 

0 REPLIES 0
Content for Community-Ad