cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1035
Views
0
Helpful
6
Replies
Highlighted

Dual DSL Copper Line failover on a 877 ?

Dear Colleagues –

I have a number of installed PPPoE 877’s with the following two problems:

1.      Our local DSLAMs do not like the Alcatel Chipset in the 877 – Consequently we have turned off the ATM interface and run a small D-link modem in bridge mode as follows:

interface FastEthernet2

description DSL interface

switchport access vlan 2

interface FastEthernet3

description DSL interface

switchport access vlan 2

!

interface Vlan2

description External DSL PPPoE

no ip address

pppoe enable group global

pppoe-client dial-pool-number 1

The above works fine – and I can manually plug the D-link into either of the FE ports to provide the required Internet access via the same ISP account logon details etc.

2.      The weakest link is, however, the Telco copper wire between the D-link modem and the DSLAM.

What I want to/need to do is to automate the manual switching of the FE ports.

To this end I have an extra (standby) D-link modem and a separate DSL line to the same DSLAM/ISP account.

What I want to achieve is: If the active link fails (loses sync)- the other links automatically takes over.

I do not want, or require, any load balancing etc – I only have one ISP account.

Can anyone help?

Everyone's tags (5)
6 REPLIES 6
Hall of Fame Master

Re: Dual DSL Copper Line failover on a 877 ?

For .1., you should update IOS and/or DSL firmware. That should make the circuit stable, eliminate the external modem, and the need for .2.

For .2. you could use an EMM script. More info in the documentation, or in the dedicated forum.

Re: Dual DSL Copper Line failover on a 877 ?

Dear Paolo -

Re 1 - As they say in the classics - Been there, done that, got the Tee-shirt. But for a one time cost of under $30 a simple DSL modem in bridge mode is a better bet. This approach also offers a range of advantages - the primary one being able to isolate the 877 from the DSL line, it then easy to determined that everything on the WAN side is A-OK (and if lightening eats it you have a $30 problem not a $300 problem).

Re 2 - Will endeavor to find out more about EMM scripting - and the dedicated forum. But a few pointers would help.

- Bill

Hall of Fame Master

Re: Dual DSL Copper Line failover on a 877 ?

1. A preference perhaps. Using native ADSL interfaces offers advantages of performance, simplicity, fault , QoS handling.

2. Just enter eem in cisco.com search box. Nothing beats getting links from the source.

Dual DSL Copper Line failover on a 877 ?

Dear EEM fellows -

I can now do wonderful EEM things like 'none events' and send emails etc.

Working on a crawl, walk run basis I would like to do the following:

I would like to monitor both DSL CDs (seems the most logical point) and in the event of loosing the CD on one line (easy to simulated - just pull the DSL plug) send an email on the other DSL line that he CD on the other line cannot be detected.   

So the question is: - a CD event detector - can anyone help

Regards - Bill

Beginner

Dual DSL Copper Line failover on a 877 ?

The DSL interfaces are actually ATM ports, right?

You can monitor this using 2 different methods:

(1) monitor for the syslog event that is generated every time the link goes down

!

event manager applet LINK-DOWN

event syslog pattern "LINEPROTO-5-UPDOWN: Line protocol on Interface , changed state to down"

!

(2) use a track object to track the interface state

!

track 100 interface e0/0 line-protocol

!

event manager applet LINK-DOWN

event track 100 state down ratelimit 360

...

!

Dual DSL Copper Line failover on a 877 ?

Hi Arie – thanks for the response

I seem to be making some progress – but I have this annoying habit of trying to understand what I do (and what I see).

I dug up an 1841 configured it as follows:

interface FastEthernet0/0

  description To dsl modem #1 to dsl line #1

  no ip address

  ip tcp adjust-mss 1452

  duplex auto

  speed auto

  pppoe enable

  pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

  description Internet access

  ip address 10.10.10.1 255.255.255.0

  ip access-group 102 in

  ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clockrate 2000000

!

interface Dialer0

ip address negotiated

ip access-group 101 in

no ip redirects

no ip unreachables

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username XYZ

ppp ipcp dns request

ppp ipcp route default

I went a stage further and connected two separate DSL lines to two D-Link ‘Bridged’ modems. I connect both of these modems, via a simple L2 switch to FE 0/0.

Both modems sync and Dialer0 connects the quickest one to sync to VI 1. And we have the following:

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES NVRAM  up                    up

FastEthernet0/1            10.10.10.1      YES NVRAM  up                    up

Serial0/0/0                unassigned      YES NVRAM  administratively down down

NVI0                       unassigned      YES unset  up                    up

Virtual-Access1            unassigned      YES unset  up                    up

Dialer0                    41.244.226.97   YES IPCP   up                    up

And I can access the Internet with the modem that won the race. Although I can see that the other modem/line has synced I can’t seem to find out how to do this from the 1841?

Now the bit that is causing me some trouble:

When I disconnect (unplug the dsl Line) from the working modem after a minute VI 1 goes down and the dialer loses the DHCP assigned IP –

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES NVRAM  up                    up

FastEthernet0/1            10.10.10.1      YES NVRAM  up                    up

Serial0/0/0                unassigned      YES NVRAM  administratively down down

NVI0                       unassigned      YES unset  up                    up

Virtual-Access1            unassigned      YES unset  down                  down

Dialer0                    unassigned      YES IPCP   up                    up

Remember that the other line/modem is still synced to the dsalm –

After about 7 to 10 minutes it finally dawns on the 1841 that this line/and modem is up – and then the 1841 re-establish connection with the Internet.

I can’t work out why the 8 to 10 minutes before the 1841 decides to connect to the alternate line?

Below is the log (with some notes)

59: 01:33:05: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

000060: 01:33:05: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

000061: 01:33:05: Vi1 DDR: Dialer statechange to up

000062: 01:33:07: Vi1 DDR: dialer protocol up

000063: 01:33:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access

1, changed state to up

Both dsl lines/modems are now up – but no indication in the log that the second line came up.

I now disconnect the dsl line that is connected to the Internet –

000064: 01:40:48: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

000065: 01:40:48: Vi1 DDR: disconnecting call

000066: 01:40:49: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to do

wn

000067: 01:40:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access

1, changed state to down

After 7 to 10 minutes the dialer wakes up and connects to the other dsl line – about 7 minutes in this case per the timestamp)

000068: 01:47:32: PPPoE 0: I PADO  R:1cdf.0f4f.f148 L:001c.f630.09d4 Fa0/0

000069: 01:47:34: PPPoE 490: I PADS  R:1cdf.0f4f.f148 L:001c.f630.09d4 Fa0/0

000070: 01:47:34: IN PADS from PPPoE Session

000071: 01:47:34: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

000072: 01:47:34: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

000073: 01:47:34: Vi1 DDR: Dialer statechange to up

000074: 01:47:36: Vi1 DDR: dialer protocol up

000075: 01:47:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access

1, changed state to up

Could you, or anyone interested, offer some ideas?

Regards - Bill

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards