cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
527
Views
0
Helpful
1
Replies

EEM, puts and terminal length

SCOTT TUDOR
Beginner
Beginner

When I run this with "event manager run jb.tcl" with 15.0(1)M2,  the "--More--" prompt interrupts the output at different points every time I run it. My terminal length is set to 35. Is there any way to get the "--More--" prompt to work correctly and interrupt the output at the line 35 marker every time?

Thanks

Scott

::cisco::eem::event_register_none

namespace import ::cisco::eem::*
namespace import ::cisco::lib::*

if { [catch {cli_open} result] } {
    error $result $errorInfo
}

array set cli $result

cli_exec $cli(fd) "enable"

puts 1
puts 2
puts 3
puts 4
puts 5
puts 6
puts 7
puts 8
puts 9
puts 10
puts 11
puts 12
puts 13
puts 14
puts 15
puts 16
puts 17
puts 18
puts 19
puts 20
puts 21
puts 22
puts 23
puts 24
puts 25
puts 26
puts 27
puts 28
puts 29
puts 30
puts 31
puts 32
puts 33
puts 34
puts 35
puts 36
puts 37
puts 38
puts 39
puts 40

catch {cli_close $cli(fd) $cli(tty_id)}

1 Reply 1

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

This looks like a bug similar to CSCsm37007 in which the more buffer is not being reset between executions.  After the first, possibly bogus --More-- prompt, you will not see another prompt until 35 lines have scrolled by.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers