cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

268
Views
0
Helpful
8
Replies
Highlighted
Beginner

enable portfast on access port

Hi 

i tried to enable portfast on endpoint port and the switch told me :

 

" Portfast has been configured on FastEthernet0/3 but will only

have effect when the interface is in a non-trunking mode. " 

 

now i did the switchport mode access ont the port but he still tell me this 

can someone explain to me ?

 

thanks

8 REPLIES 8
Highlighted
VIP Mentor

Re: enable portfast on access port

can you post below output

 

show run interface FastEthernet0/3

 

or do the below steps :

 

config t

default interface FastEthernet0/3

interface FastEthernet0/3

spanning-tree portfast

!

end

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: enable portfast on access port

thanks for the reply
i did what you said and it didnt work
Highlighted
Collaborator

Re: enable portfast on access port

 

Note that there is special command for trunks, spanning-tree portfast trunk, to enable portfast on trunks (for special occasion); so, spanning-tree portfast is applied to access ports only and not to trunks while spanning-tree portfast trunk applies to trunks.

this message makes sense If a interface is a trunk, and you apply command without "trunk" option.  it is just nice reminder from Cisco.

in case of "hard coded" access point, I have to check with real switch (don't have access right now).  I think you doing this on PT, right?  Still, I think the same message is there anyway.

 

Regards, ML
**Please Rate All Helpful Responses **

Highlighted
Beginner

Re: enable portfast on access port

thank for the reply
but the port is access and not trunk, and yes its in packet tracer
Highlighted
VIP Mentor

Re: enable portfast on access port

unfortunatly i am no user of Packet tracer, so i have advise real kit example. (this should work also in emulated or simulated world) i used GNS/PNET/EVE

BB
*** Rate All Helpful Responses ***
Highlighted
Collaborator

Re: enable portfast on access port

 

Yes, but it doesn't matter; Portfast feature is still applied and works whether you manually configured port to be access one Or switch port is set to default value (dynamic auto/static access).   Maybe it is a bug or  that message is informative in nature and not tied to port status. it is like saying " ok, btw, this will work only .."

 

Same message showed up on my virtual switch lab.  I get some examples from my virtual ios (used in CCIE RS lab and very close to real gear);

Regards, ML
**Please Rate All Helpful Responses **

Highlighted
Collaborator

Re: enable portfast on access port

 

attached is my test.  All my switch ports are dynamic auto and static access by default with DTP running (dynamic auto). No matter what I do, "%Portfast has been configured on .... but will only have effect when the interface is in a non-trunking mode."  still shows up.

I wouldn't worry too much about that message; as long as portfast is applied - which it is;

to see if portfast is applied and where, use SHOW SPANning-tree INTerface x/y DETAIL  command and look for "The port is in the portfast edge mode" message.

 

Regards, ML
**Please Rate All Helpful Responses **

 

Highlighted
Beginner

Re: enable portfast on access port

it is not on portfast edge mode ( its on P2p )
Content for Community-Ad