Showing results for 
Search instead for 
Did you mean: 

Exporting maps from WCS to Prime

Hi all,

I have a really specific problem with exporting maps from WCS to Cisco PI 1.3. Here is the procedure I'm using to export:

1. Login to WCS

2. Monitor > Maps > Export Maps...

3. Include map information is selected, same as Select all maps.

4. Export is downloaded in a .tar archive.

5. Login to Cisco PI 1.3 with root credentials

6. Operate > Maps > Import maps...

7. XML format

8. Select the .tar.gz output from WCS

After running the import I get this error for all APs:

Invalid X Coordinate position. Position lies outside floors Max Permissible Height,AP will be snapped at max floor height.

I have a huge amount of access points so manually adding them and fixing location data is not an option. Has anyone encountered this problem before ?

WCS is running on version while Prime is

NCS/admin# show ver

Cisco Application Deployment Engine OS Release: 2.0

ADE-OS Build Version:

ADE-OS System Architecture: x86_64

Copyright (c) 2005-2010 by Cisco Systems, Inc.

All rights reserved.

Hostname: NCS

Version information of installed applications


Cisco Prime Network Control System


Version :


Predrag Petrovic       

Predrag Petrovic
Rob Johnson
Cisco Employee

You might be hitting bug CSCtj67448--

My recommendation is to get a good backup of your current system, upgrade it to then run your export again.

Hi Rob,

The thing is we are migrating from WCS to Prime. And now we have done everything except the maps and few smaller issues since we are hitting bugs which will be fixed in 2.0 version of Prime. I wanted to check if someone else has faced similar issues with the maps. Regarding the upgrade, I'm not sure that we are entitled to upgrades / updates for WCS. One of the reasons I can see which is happening is that the XML file does not contain any coordinates for the APs, the values are null.

I have tried both measurements, feet and cm/m and its the same result at the end.

Predrag Petrovic

Predrag Petrovic

Not sure what's causing the map export issue:::

I would either:::

1) upgrade the WCS to then try the export again

2) spin up an NCS box then go through the ncs migrate process then, once into NCS, migrate to Prime

I had this issue also. Upgrading to solved the problem.