cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
881
Views
0
Helpful
2
Replies

How to: Bandwidth limitation by IP address- Cisco 831

brianjp2472
Level 1
Level 1

How do you do it? What are the exact lines I need to input? I have researched this online and I think there is a way using CAR, but I just get more confused. here is my current config below. I appreciate any help.

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service dhcp

!

hostname xxxxx

!

enable secret xxx

enable password xxx

!

username admin password xxx

ip subnet-zero

ip domain name xxxxx

ip name-server x.x.x.x

ip name-server x.x.x.x

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool CLIENT

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

lease 0 2

!

ip dhcp pool xxxxx

!

ip audit notify log

ip audit po max-events 100

ip ssh source-interface Ethernet0

ip address-pool dhcp-pool

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

!

!

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface Ethernet1

ip address dhcp

ip nat outside

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxx

ppp chap password xxx

ppp pap sent-username xxxx password xxx

!

ip nat inside source list 101 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

!

!

access-list 101 permit ip host 10.10.10.8 any

access-list 101 permit ip host 10.10.10.36 any

access-list 101 permit ip host 10.10.10.39 any

access-list 101 permit ip host 10.10.10.54 any

access-list 101 permit ip host 10.10.10.55 any

access-list 101 permit ip host 10.10.10.63 any

access-list 101 permit ip host 10.10.10.78 any

access-list 101 permit ip host 10.10.10.85 any

access-list 101 permit ip host 10.10.10.90 any

access-list 101 permit ip host 10.10.10.91 any

access-list 101 permit ip host 10.10.10.92 any

access-list 101 permit ip host 10.10.10.102 any

access-list 101 permit ip host 10.10.10.116 any

access-list 101 permit ip host 10.10.10.123 any

access-list 101 permit ip host 10.10.10.126 any

access-list 101 permit ip host 10.10.10.127 any

access-list 101 permit ip host 10.10.10.134 any

access-list 101 permit ip host 10.10.10.144 any

access-list 101 permit ip host 10.10.10.158 any

!

line con 0

exec-timeout 120 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

exec-timeout 120 0

login local

length 0

!

scheduler max-task-time 5000

end

2 Replies 2

owillins
Level 6
Level 6

go through this document Cisco 800 Series Routers Configure

http://www.cisco.com/en/US/products/hw/routers/ps380/tsd_products_support_configure.html

basically you need a class map, a policy map and an access-list matching your clients and apply that to your interface.

class-map match-any clients

description limited clients

match access-group 89

policy-map clients

class clients

shape average 512000

access-list 89 permit 10.x.x.x

M.