cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
300
Views
10
Helpful
3
Replies

Implementation of ROAS (Router-On-A-Stick) for inter VLANs communicati

mallawar123
Beginner
Beginner

Implementation of ROAS (Router-On-A-Stick) for inter VLANs communication in L2 Switches
with Network Redundancy at Remote Area Smaller Network with Internet Access
========================================================================

ROAS is best suitable for smaller networks at remote area, SVI(Switch Vertual Interface),
Switch Roted Port and EtherChannels are most suitable for large area network.

Differences are:
-ROAS uses VLAN uniq id numbers in Router's subinterfaces with IP address to egress/ingress data packet/frame,
-SVI uses each VLAN as a interface with IP address, one of VLAN interface act to egress/ingress data packet/frame,
-Switch Routed Port - in the switch one port act similler to Router port (no VLAN involvement) to egress/ingress data packet/frame,
-EtherChannels are pair of Point-to-point links connected between two switches. Port-channel/channel-group number act as interface to egress/ingress data packet/frame.

Here I implement ROAS in L2 Switches connected to two Routers with redundancy of Mesh Network topology.
Head office and three Brach offices connect to Mesh topology for network redundancy.

VLAN 10- Admin
VLAN 20- Sales
VLAN 30- Finance
VLAN 40- Operation

Switches
=========
1. Core-SW1 - Head Office
2. BOA-SW2 - Branch office A
3. BOB-SW3 - Branch office B
4. BOC-SW4 - Branch office C

Each brach office exists all VLANs-10,20,30,40

ROAS-VLANs-L2SW-RedundancyROAS-VLANs-L2SW-Redundancy

Each Switch (Core-SW1,BOA-SW2,BOB-SW3,BOC-SW4) have to Configure with same VLAN numbers.
==================================================================================
1. Create VLANs

Switch>enable
Switch#config t
Switch(config)#vlan 10
Switch(config-vlan)#name Admin
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name Sales
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name Finance
Switch(config-vlan)#vlan 40
Switch(config-vlan)#name Operation
Switch(config-vlan)#exit
Switch(config)#

2. Assigning Trunk mode and VLANs for Core-SW1 switchports.

Switch(config)#
Switch(config)#int rang g0/1
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/1-5
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/6-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/11-15
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/16-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/21-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#

3. Assigning trunk mode and VLANs to rest of the each Switch(BOA-SW2,BOB-SW3,BOC-SW4)Switchports

Switch(config)#
Switch(config)#int rang g0/2
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#no shut
Switch(config)#
Switch(config)#int rang f0/1-6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/7-12
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/13-18
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#no shut
Switch(config-if-range)#int rang f0/19-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#


Configuration of Routers (ROAS1 and ROAS2)
===========================================

1. Create DHCP Pool Net in both routers (ROAS1 & ROAS2) for each VLANs client machines (IP address assignment will take automatically for each client machine in all VLANs)

ROAS1#conf t
ROAS1(config)#
ROAS1(config)#ip dhcp excluded-address 10.40.4.1 10.40.4.4
ROAS1(config)#ip dhcp excluded-address 10.30.3.1 10.30.3.4
ROAS1(config)#ip dhcp excluded-address 10.20.2.1 10.20.2.4
ROAS1(config)#ip dhcp excluded-address 10.10.1.1 10.10.1.4
ROAS1(config)#
ROAS1(config)#ip dhcp pool Net10
ROAS1(dhcp-config)# network 10.10.1.0 255.255.255.0
ROAS1(dhcp-config)# default-router 10.10.1.1
ROAS1(dhcp-config)#ip dhcp pool Net20
ROAS1(dhcp-config)# network 10.20.2.0 255.255.255.0
ROAS1(dhcp-config)# default-router 10.20.2.1
ROAS1(dhcp-config)#ip dhcp pool Net30
ROAS1(dhcp-config)# network 10.30.3.0 255.255.255.0
ROAS1(dhcp-config)# default-router 10.30.3.1
ROAS1(dhcp-config)#ip dhcp pool Net40
ROAS1(dhcp-config)# network 10.40.4.0 255.255.255.0
ROAS1(dhcp-config)# default-router 10.40.4.1
ROAS1(dhcp-config)#exit
ROAS1(config)#

2. ROAS1 Configuration.
Create sub-interfaces, assigned VLAN uniq ID and IP address for sub-interfaces in ROAS1
-----------------------------------------------------------------------------------------
In the ROAS1 router G0/0 interface

ROAS1(config)#
ROAS1(config)#interface GigabitEthernet0/0
ROAS1(config-if)# no ip address
ROAS1(config-if)# ip nat inside
ROAS1(config-if)# no shutdown
ROAS1(config-if)#
ROAS1(config-if)#interface GigabitEthernet0/0.10
ROAS1(config-subif)# encapsulation dot1Q 10
ROAS1(config-subif)# ip address 10.10.1.1 255.255.255.0
ROAS1(config-subif)#
ROAS1(config-subif)#interface GigabitEthernet0/0.20
ROAS1(config-subif)# encapsulation dot1Q 20
ROAS1(config-subif)# ip address 10.20.2.1 255.255.255.0
ROAS1(config-subif)#
ROAS1(config-subif)#interface GigabitEthernet0/0.30
ROAS1(config-subif)# encapsulation dot1Q 30
ROAS1(config-subif)# ip address 10.30.3.1 255.255.255.0
ROAS1(config-subif)#
ROAS1(config-subif)#interface GigabitEthernet0/0.40
ROAS1(config-subif)# encapsulation dot1Q 40
ROAS1(config-subif)# ip address 10.40.4.1 255.255.255.0
ROAS1(config-subif)#exit
ROAS1(config)#

In the ROAS1 router G0/1 interface assigned an IP address to egress/ingress packet/frame to Internet access ISP router
ROAS1(config)#
ROAS1(config)#interface GigabitEthernet0/1
ROAS1(config-if)# ip address 192.168.9.1 255.255.255.252
ROAS1(config-if)# ip nat outside
ROAS1(config-if)# no shutdown
ROAS1(config-if)#
ROAS1(config-if)#
ROAS1(config-if)#interface Vlan1
ROAS1(config-if)# no ip address
ROAS1(config-if)# shutdown
ROAS1(config-if)#exit
ROAS1(config)#

Internal all trafic forward to Internet access ISP router
ROAS1(config)#
ROAS1(config)#ip route 0.0.0.0 0.0.0.0 192.168.9.2
ROAS1(config)#

3. ROAS2 Configuration.
Create sub-interfaces, assigned VLAN uniq ID and IP address for sub-interfaces in ROAS2
-------------------------------------------------------------------------------
ROAS2#conf t
ROAS2(config)#
ROAS2(config)#interface GigabitEthernet0/0/0
ROAS2(config-if)# no ip address
ROAS2(config-if)# ip nat inside
ROAS2(config-if)#
ROAS2(config-if)#
ROAS2(config-if)#interface GigabitEthernet0/0/0.10
ROAS2(config-subif)# encapsulation dot1Q 10
ROAS2(config-subif)# ip address 10.10.1.1 255.255.255.0
ROAS2(config-subif)#
ROAS2(config-subif)#interface GigabitEthernet0/0/0.30
ROAS2(config-subif)# encapsulation dot1Q 30
ROAS2(config-subif)# ip address 10.30.3.1 255.255.255.0
ROAS2(config-subif)#exit
ROAS2(config)#
ROAS2(config)#interface GigabitEthernet0/0/1
ROAS2(config-if)# no ip address
ROAS2(config-if)# ip nat inside
ROAS2(config-if)#
ROAS2(config-if)#interface GigabitEthernet0/0/1.20
ROAS2(config-subif)# encapsulation dot1Q 20
ROAS2(config-subif)# ip address 10.20.2.1 255.255.255.0
ROAS2(config-subif)#
ROAS2(config-subif)#interface GigabitEthernet0/0/1.40
ROAS2(config-subif)# encapsulation dot1Q 40
ROAS2(config-subif)# ip address 10.40.4.1 255.255.255.0
ROAS2(config-subif)#exit
ROAS2(config)#

In the ROAS2 router G0/0/2 interface assigned an IP address to egress/ingress packet/frame to Internet access ISP router
ROAS2(config)#
ROAS2(config)#interface GigabitEthernet0/0/2
ROAS2(config-if)# ip address 192.168.9.5 255.255.255.252
ROAS2(config-if)# ip nat outside
ROAS2(config-if)# no shutdown
ROAS2(config-if)# exit
ROAS2(config)#

Internal all trafic forward to Internet access ISP router
ROAS2(config)#
ROAS2(config)#ip route 0.0.0.0 0.0.0.0 192.168.9.6
ROAS2(config)#


4. Internet-R1 router configuration
---------------------------------------
Internet-R1#config t
Internet-R1(config)#
Internet-R1(config)#interface GigabitEthernet0/0/0
Internet-R1(config-if)# ip address 192.168.9.2 255.255.255.252
Internet-R1(config-if)# ip nat inside
Internet-R1(config-if)#
Internet-R1(config-if)#
Internet-R1(config-if)#interface GigabitEthernet0/0/1
Internet-R1(config-if)# ip address 192.168.9.6 255.255.255.252
Internet-R1(config-if)# ip nat inside
Internet-R1(config-if)#
Internet-R1(config-if)#
Internet-R1(config-if)#interface Vlan1
Internet-R1(config-if)# no ip address
Internet-R1(config-if)# shutdown
Internet-R1(config-if)#exit
Internet-R1(config)#

Internal all trafic allows to Internet access ISP router
Internet-R1(config)#
Internet-R1(config-if)#ip route 0.0.0.0 0.0.0.0 192.168.9.5
Internet-R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.9.1
Internet-R1(config)#

 

 

3 Replies 3

Martin L
VIP Advisor VIP Advisor
VIP Advisor

Thanks for sharing; if possible attach PT file here (must be zipped); thanks !!!

Hello Martin,

Do you mean Project File (PT) of this implementation that you want ?

This is a solution for all who wants to implement ROAS-inter Vlan communication to do correct implementation with redundancy.

Best regards/Mallawar

Yes, if you already have one made; if not, we can make its own.

Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers