Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


IOS upgrade failure,any ideas ?


I tried to update an ios upgrade remotely (silly I know !) and have run in to a pretty major problem. I was wondering if any one had any ideas before i jumped in to my car....

The router is a cisco3640 and it was running ios 11.1. I backed this up and then tried to load 12.3 on to the router. It downloaded the image fine, the checksum was fine and the running config was still there.

I therefore decided to reboot. The router recognised there had been a config change and asked me if I wanted to save the changes. I hit yes and the router rebooted.

It hasnt come back up !

It is being used as an ISDN30 RAS router at present and I was wondering if anyone had any ideas of what may have gone wrong or indeed what I can expect if I have to drive down there.......




Re: IOS upgrade failure,any ideas ?

If you didn't erase the flash before loading the IOS it may fail.

The IOS needs to be the first item in flash to load. If it's not, it can still be found if you use the "boot system" command. Something like "boot system flash:[iosimagename]" should work.

I did this once with the SDM files installed. flash used to have "IOS & SDM files"; I erased the IOS, and loaded anotherone without erasing ALL flash. This left the files in the order: "SDM files & newIOS"; and the router dropped into ROMMON mode unable to find an IOS image.

Also there could be some sort of change in config options from 11.1 to 12.3 (that's a huge jump). Something critical may have changed (syntax-wise) and isn't working now.


Re: IOS upgrade failure,any ideas ?

many thanks for that,

I have arrived on site and found the following :

The router stuck in rommon mode and when I enter the "boot system" command I get the following : (see attachment )

Just to clarify, the router is a 3640 with 8mb flash in it. It has installed 2 netowrk modules, 1 digital modem bank and 1 isdn30 interface. It previously ran 12.1 (not 11.1 as I said) and Iam trying to upgrade to 12.3.

If this is a shortage of memory problem can I borrow some from somewhere else on the router ( iomem command ? ).

Any help greatly appreciated...


Re: IOS upgrade failure,any ideas ?

Hall of Fame Master

Re: IOS upgrade failure,any ideas ?

The link that Shawn sent is a good one.

I strongly suspect that you do not have enough memory on the router to run the image that you loaded. And I doubt that you can get around it without either adding more memory or by loading an image that has less memory requirements.

To get back to a working state while you decide what you long term solution will be I suggest that you load the original IOS back onto the 3640. Your original post indicated that you had backed that up (smart move !) and hopefully you have access to it from where you are.



If you found this post helpful, please let the community know by clicking the helpful button!
By doing so, and until end of January, you are helping Doctors Without Borders

Re: IOS upgrade failure,any ideas ?

Thanks to both of you for you help on this , I have solved the problem and it was a lack of memory on the router.

Basically I removed all the NM's and the router booted fine. I added them one at at a time and it always failed on the PRI card.

I fortunately had brought down with me a spare router (in case things got really bad !) and I "borrowed" 16mb from this. With extra memory installed everything is booting ok and working as it should be.

All is now working well with the new ios,

thanks again,


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards