cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1163
Views
3
Helpful
5
Replies

LMS 3.2 (3750+Nexus7000+VSS) Device Compatibility patch ?

Hi all,

I'm trying to get a feedback from Cisco about a device compatibility patch for CiscoWorks LMS 3.2.

I need to integrate new devices in LMS 3.2 :

- 3750X

- Nexus 7000

- VSS (6500 chassis).

Are you able to tell me where I can find this kind of patch ?

I'm not able to find anything else than CiscoView patch, but I need the complete hardware compatibility in CiscoWorks.

Thank you.

Regards,

St.

5 REPLIES 5
Joe Clarke
Hall of Fame Cisco Employee

You may not need any patches to support these devices.  At least VSS support is already built-in to LMS 3.2 for Campus Manager, RME, and DFM.  However, to confirm you have the full set of device support, go to Common Services > Software Center > Device Updates.  Check the boxes next to Common Services, RME, Campus Manager, DFM, and CiscoView.  Download and install all available updates, and you should have full device support.

Hi Joseph,

Thank you for your update.

But, my LMS 3.2 is not patched. All the packages version are out of date, from 06 Oct 2009.

When I go to Common Services > Software Center > Device Updates, for example with RME, I have RME 4.3.0 and not 4.3.1 !

When I check it, the DOWNLOAD UPDATE button stay GREY and I cannot click on it to download software.

Is it a Bug or have I done something wrong ? Could you tell me how to solve this, because I need to patch every packages : CiscoView, RME, CM, DFM...

(Edit : No problem, I just forget to use admin account instead)

But When I try to do the update, I have an error in the log psu.log :

[ Tue Feb 15 14:10:20 CET 2011 ] INFO   [SecurityHandler : getCSProxyLogin]  : No proxy User Name configured
[ Tue Feb 15 14:10:37 CET 2011 ] INFO   [DevUpdate : performAdd]  : Validated Cisco.com credentials..
[ Tue Feb 15 14:10:38 CET 2011 ] WARN   [DownloadManager : queryAllPkgs]  : Error setting permissions for readme subdirectories.
[ Tue Feb 15 14:10:39 CET 2011 ] INFO   [CcoDownloadAdapter : getXmlFileList]  : Connected to Cisco.com...
[ Tue Feb 15 14:10:39 CET 2011 ] WARN   [XmlManager : getPsuPackages]  : No packages available
[ Tue Feb 15 14:10:39 CET 2011 ] ERROR  [RemoteRepSync : downloadPsuHeadersAsXml]  : No packages found for the searchStr &SEARCH=lmsportal||1.2.0||Device%20Pa
ckage|||&FORMAT=XML
[ Tue Feb 15 14:10:39 CET 2011 ] WARN   [RemoteRepSync : getAllPackagesFor]  : No packages available for product : lmsportal
[ Tue Feb 15 14:10:41 CET 2011 ] INFO   [CcoDownloadAdapter : getXmlFileList]  : Connected to Cisco.com...
[ Tue Feb 15 14:10:41 CET 2011 ] ERROR  [RemoteRepSync : downloadPsuHeadersAsXml]  : VDSException thrown com.cisco.nm.xms.vds.VDSException:  failed: com.cisco
.nm.xms.vds.VDSException: failed to connect to Cisco.com::Moved Temporarily
[ Tue Feb 15 14:10:42 CET 2011 ] ERROR  [ViewRemoteAndInstalledPkg : getRemoteAndInstalledPkg]  : VDSException while downloading headers from Cisco.com
com.cisco.nm.xms.vds.VDSException:  failed: com.cisco.nm.xms.vds.VDSException: failed to connect to Cisco.com::Moved Temporarily
        at com.cisco.nm.xms.psu.downloadmgmt.RemoteRepSync.downloadPsuHeadersAsXml(RemoteRepSync.java:507)
        at com.cisco.nm.xms.psu.downloadmgmt.RemoteRepSync.getAllPackagesFor(RemoteRepSync.java:732)
        at com.cisco.nm.xms.psu.downloadmgmt.DownloadManager.queryAllPkgs(DownloadManager.java:1122)
        at com.cisco.nm.xms.psu.ui.gui.model.ViewRemoteAndInstalledPkg.getRemoteAndInstalledPkg(ViewRemoteAndInstalledPkg.java:169)
        at com.cisco.nm.xms.psu.ui.gui.model.action.DevUpdate.performAdd(DevUpdate.java:1032)
        at com.cisco.nm.xms.psu.ui.gui.model.action.DevUpdate.perform(DevUpdate.java:555)
        at org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:509)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:128)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:199)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:282)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:754)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:684)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:876)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
        at java.lang.Thread.run(Thread.java:595)

Joe Clarke
Hall of Fame Cisco Employee

This is a known problem with Cisco.com.  We're working to resolve it.  In the meantime, you can download RME updates directly from http://www.cisco.com/cisco/software/type.html?mdfid=282635175&flowid=5145 .  The RME 4.3.1 patch for Windows can be downloaded from http://www.cisco.com/cisco/software/release.html?mdfid=282635175&flowid=5145&softwareid=280775120&os=Windows&release=4.3.1&relind=AVAILABLE&rellifecycle=&reltype=latest .

Hi Joseph,

Thank you for your answer.

So, there is any way to solve this temporary ? I need to download each patch, each module software and install them manually.

This is what I done yersteday, I downloaded the RME 4.3.1 Software for Solaris (ZIP file) and installed it manually, but without any patch.

Joe Clarke
Hall of Fame Cisco Employee

For right now, manually downloading each package is required.  We're working quickly to get this resolved on Cisco.com.

Content for Community-Ad