cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
835
Views
3
Helpful
5
Replies
Highlighted
Beginner

LMS 3.2. Campus Manager (5.2.1) and devices in "Not Managed" state

Hi,

I have enabled auto mode and manually included but when I run a data collection some devices don't take part in the process. When I click in show included devices I can see 19 devices in Not Managed state. What is this? How can I fix it?

I attach ani.log file

Thanks

5 REPLIES 5
Highlighted
Contributor

Verify Auto Managed is enabled in Campus Manager:

  • Campus Manager > Admin > Data Collection > Mode and Policy  Settings
  • Check the box "Enable Auto Mode" and apply.
  • Check include and exclude devices and ensure "Show Included Devices and Show Excluded Devices" does not populate.
Highlighted

Yes, Auto Managed is enabled

Highlighted
Beginner

a TAC case was logged on this issue:

the debugging in the ani.log showed that the devices were not managed because they wre arleady part of a management cluster:

com.cisco.nm.ani.server.frontend.EvalTerminateAndRemoveException: Removing
duplicate cluster member device ....


we have toggled off cluster discovery by setting the below value in the ANISERVER.PROPERTIES and restarting the ANIServer process, after that all devices were managed correctly:

Discovery.Cluster=OFF
Highlighted

hi, I have changed it too off but after running discovery again it has not changed, still there are 9 missing devices !!!

Highlighted

Finally I found the reason why my devices are in included devices ;

it was very simple because I have too many same hostnames,  I changed the hostname to be unique and it still have those devices in the included !!!  after every changing we you to reinitialize the ANI server with the apropriate command (

NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=ani dmprefix=ANI

and then start the discovery .

It is finished

Content for Community-Ad