cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
869
Views
0
Helpful
2
Replies
kkolander
Beginner

LMS 4.0.1 reinitdb.pl doesn't work

Hello,

I have upgraded and migrated the data from LMS 3.2 to LMS 4.0.1.

The User Tracking is active. Now I have a problem.

After the User Tracking Aquisition I have only complete new users in the database, not the other ones (learned in LMS 3.2).

The aquisition ends in error with "SQL Anywhere Error -193: Primary key for table 'NewMAC' is not unique."

I found in this Support Community, this is a problem with the User Tracking data migrated from LMS 3.2 and stale entries in the database.

I've tried to reinit the database with the command "perl reinitdb.pl -restore -ut". Here I got the message "USAGE: reinitdb.pl [options]...".

I tried "reinitdb.pl -restore -ut". The cursor jumped into the next row and a perl.exe-process was started. But nothing else happens, not even in the next few hours.

A new UT-Aquisition showed the same result as above.

The new LMS-Server is a Windows-2008-Server.

Has anyone any ideas, why the reinitdb.pl doesn't work?

Regards,

Kerstin Kolander

2 REPLIES 2
Svetlana Radzevich
Cisco Employee

Hi Kerstin,

try to specify the full path for the perl.exe (the file is under $NMSRoot\bin directory) in the command. If still problem, please post the full output of the commands.

Svetlana

Hi Svetlana,

thanks for your post. The User Tracking is now working. I think, the database was reinitialized

although I have not get proper output.

Kerstin

Content for Community-Ad