cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1670
Views
5
Helpful
6
Replies

LMS 4.0 Devices in DFM are showing IP address for Device Name field

edgertonj
Level 1
Level 1

I have added all of the devices to DCR and they show up with their hostname value in all of the device trees except for the fault manager views. In all of the fault manager views the hostname is not being used for the Devie Name field, rather the IP address is being used. I'm not sure how to fix it. Any suggestions would be greatly welcomed.

--

Jason Edgerton

1 Accepted Solution

Accepted Solutions

Interesting Afroj

I usually resolve this type of situation by creating a hosts file entry for all devices not in DNS.

Will this approach update the DFM hostnames or does one still need to remove and re-add the devices from DFM for it to be discovered witht he correct name?

I sure hope cisco will come clean on this issue one day and use the DisplayName like in the other LMS applications.

Cheers,

Michel

View solution in original post

6 Replies 6

AFROJ AHMAD
Cisco Employee
Cisco Employee

Hi Jason,

By default DFM always show devices with IP address., you can try the below workaround and I hope this will work for you:

Workaround:

1> Add the Device Name and IP on the DNS Server

2> Modified NMSROOT/objects/smarts/conf/discovery/discovery.conf, and changed the DisplayNameFormat from "AUTOASSIGNED" to "MIBIISYSNAME". 

That caused DFM to display the sysName as the display name.

Also set the NameFormat to TM_USEAUTONAME, then restarted daemon Manager (net stop crmdmgtd && net start crmdmgtd )

3> Delete and re-add a device in DFM

Thanks

Afroj

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Interesting Afroj

I usually resolve this type of situation by creating a hosts file entry for all devices not in DNS.

Will this approach update the DFM hostnames or does one still need to remove and re-add the devices from DFM for it to be discovered witht he correct name?

I sure hope cisco will come clean on this issue one day and use the DisplayName like in the other LMS applications.

Cheers,

Michel

Hi Michel,

If DFM has already discovered the devices with IP address then after creating the DNS entry for the devices , you need to Re-discover the devices in DFM.

Kindly check this:

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_device_fault_manager/3.2/user/guide/useDevMg.html#wp1367528

I too hope so that one day DFM will use the DisplayName like in the other LMS applications

Thanks

Afroj

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Jason,

Glad this works for you.

Afroj,

I meant the method you provide, does it require a remove add of the device in order to provoke a new lookup of the name displayed in the application?

I know that the DNS update only works when a devices is removed re-added.

Cheers,

Michel

Hi Michel,

yes we need to delete and re-add the device to provoke the new lookup of the name displayed in the application.

Thanks

Afroj

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

I tried modifying the discovery.conf file as mentioned in the first reply and then the net stop and start. The didn't change the behavior.

Modyfing the hosts file as suggested in the second reply fixed the issue for me. Thanks for the replies!