cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1218
Views
5
Helpful
26
Replies
Highlighted
Beginner

LMS 4.0 no longer working after reboot

I have LMS v4.0 installed and was it working fine (Windows Server 2008R2 Std).

However, I had call to reboot the physical server last week (it had been up for over 6 months) and I am now having problems with most options under the Inventory menu.

I have attached screenshots of the errors I am getting and the end of the DCRServer.log file which indicates that the DCR server has started ok.

I have disabled the DHCP Client service as I saw in another post that this has been known to cause the issue I am seeing, but that has not made any difference.

I have exhausted everything I can think of and am hoping that someone on here can give me some advice or ideas as to where to look next.

Thanks

Steve

26 REPLIES 26
Highlighted
Cisco Employee

Hi Steve,

share the output of pdshow

and below files

md.properties (NMSROOT\CSCOpx\lib\classpath)

ctm_config.txt file  from NMSROOT\CSCOpx\MDC\tomcat\lib  and

NMSROOT\CSCOpx\MDC\tomcat\shared\lib

and last 200 lines of syslog.log

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroz, thanks for the super fast response

Please find everything attatched.

I do not have a ctm_config.txt file in NMSROOT\CSCOpx\MDC\tomcat\lib, the one attached is from NMSROOT\CSCOpx\MDC\tomcat\shared\lib.

The syslog file is over 1.6Gb so it may take me a while to open that one - will post it as soon as I have managed to extract the last 200 lines.

Highlighted

Hi Steve,

Some Major processes are down.

    Process= EssentialsDM

    State  = Administrator has shut down this server

     Process= ConfigMgmtServer

    State  = Administrator has shut down this server

    Process= CTMJrmServer

    State  = Administrator has shut down this server

    Process= ANIServer

    State  = Administrator has shut down this server

Follow the below steps:

1.shutdown daemon manager(net stop crmdmgtd)

2.then remove ctmregistry* from NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib.

3. Regenrate the SSLcertificate :

3.1. Remove the following certificate files from (NMSROOT/MDC/Apache/conf/ssl)

a. server.crt

b. server.key

c. server.pk8

3.2 Disable SSL: NMSROOT/bin/perl  "NMSROOT/MDC/Apache/ConfigSSL.pl" -disable

3.3. Enable SSL to generate certificate:

NMSROOT/bin/perl "NMSROOT/MDC/Apache/ConfigSSL.pl" -enable

4. start the daemon manager (net start crmdmgtd)

Also make sure the casuser is a part of ADMINISTRATOR Group. 

one last thing , Reset the casuser as well.

NMSROOt/CSCOpx/setup/support>resetCasuser.exe

Hope it will help.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroj,

Thanks for that, I have followed the instructions you posted and a pdshow now shows all the processess listed in your reply above as all running ok.

However, now I cannot even login. After entering the correct username/password I get:

Forbidden

You don't have permission to access /cwhp/LiaisonServlet on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

I therefore disabled the SSL Cert again ( NMSROOT/bin/perl  "NMSROOT/MDC/Apache/ConfigSSL.pl" -disable) and restarted the Daemon which now allows me to login ok.

However I am now back to the original problem of most options in the Inventory menu saying "Error in communicating with DCR Server".  A pdshow shows all the services you referred to originally are all running ok.


Highlighted

Hi steve ,

try with port 443.

thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Afroj,

Just to clarify...

I currently have a shortcut (on the LMS server) that fires up a browser with a URL of http://servername:1741

Should I re-enable the SSL (NMSROOT/bin/perl "NMSROOT/MDC/Apache/ConfigSSL.pl" -enable), restart the Daemon and then attempt to browse to https://servername  ???

Thanks

Steve

Highlighted

http://servername:443

can you try above and see how it works

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroj,

I re-enabled the SSL, stopped/started the Daemon and browsed to http://servername:443

I just get a totally blank white page (no errors).

Using the original shortcut (http & port 1741), I get the "There is a problem with this website's security certificate." (which I have always had), continue and enter the logon credentials, it then throws up the Forbidden error I posted above.


Highlighted

Steve,

let it be disabled Only.

DO not delete any files just run the  -disable command and login again.

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Afroj,

Have done the -disable and restarted Daemon.

Browsing to http://servername:443 just gives totally blank white page.

Browsing to http://servername:1741 allows me to login (after getting warning about certificate which is normal), but I have the original error within the Inventory menu - Error in communicating with DCR Server.

Current pdshow output attached.


Highlighted

Processses are fine ..

copy the  the ctm_config.txt file to all the location. we need to have this file on all the three location.

/NMSROOT/MDC/tomcat/shared/lib/
/NMSROOT/MDC/tomcat/webapps/cwhp/WEB-INF/lib/
/NMSROOT/MDC/tomcat/lib/

One more thing add  the LMS server hostname and ip address in the hosts file C:\Windows\System32\drivers\etc

Thanks-
Afroz
Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

I dont have a /NMSROOT/MDC/tomcat/lib/ directory.


Where should I copy the ctm_config.txt file from, there is already one in the other two directories.

Have added 4 entries to the hosts file:

server name in lowercase

server name in uppercase

localhost

and FQDN servername in lowercase

Highlighted

can  you share the error.log and apache.log from NMSROOT/CSCOpx/MDC/apache/logs

Stdout.log from NMSROOT/CSCOpx/MDC/tomcat/logs

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroj,

I dont have a apache.log file.

Have attached the error.log & stdout.log as requested.

For some reason , I dont think it is starting properly now - I do not get any emails of down devices when it starts up which I have always had before, and the processes you references in your first response are sat at 'Never started' again.

Couple of things:

Should the hostname when generating the certificate be the FQDN or not (I regenerated WITHOUT as I found another post alluding to this)

Should the hosts file point all the variations of serername to the actual IP or the 127.0.0.1 loopback?

I also notice that on the Monitor-Dashboards-Monitoring screen I get th attached error.

Steve

Content for Community-Ad