Showing results for 
Search instead for 
Did you mean: 

LMS 4.1 - Manage Devices States is empty but not the inventory ?!

Hi Guys !

I'm encountering a very strange problem....

Please, look @ the joined files (2x Jpeg files showing the problem)

When I'm going to the Inventory > Device Administration > Add / Import / Managed devices

All my devices are listed there.

When I'm going to the Inventory > Device Administration > Manage Device States

The list shows 0 devices !!!

I'm encountering problem when I'm trying to generate PSIRT / EOL reports, NetConfig, and so on...

Do you have an idea to restore this ?

I tried to delete 1 device, and recreate it, but nothing more happened ! Managed Devices list is still @ 0.

I'm scared of Restore Default Database, because I don't want to lose every Config Version Tree, etc...

What's the best way to solve this issue ?

Thank you for all your ideas !!!


5 Replies 5

Vinod Arya
Cisco Employee
Cisco Employee

Is it a new install? Or new install with DB restored from previous LMS version? under Inventory > Device Administration > Add / Import / Managed devices I dont see any device icon and hence not sure if the devices are managed properly.

Once a device is managed it should automatically show some icons.

Is invenotry collection successful for any device?? if yes are you able to generate detailed device report in Inventory and see all details successfully?

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Hello Vinod,

Thanks for your answer.

It's a new installation, with only a Bulk Import of devices from XML file.

You don't see any icons, you are right !

Before encoutering this issue, LMS was able to show us and recognize the correct icons and devices (6500, 3750, mds, etc..). Now it's flagged as "Unknown Device".

Since the "Manage Device State" show us 0 devices everywhere, we lost the icons !

Yes, the inventory collection is successful for all devices (except for one or two...).

Yes, I'm able to generate a detailed device report for devices which are showing correctly the data and details from this device.

Any idea ?


This is strange issue and I have seen only in LMS 4.1. Unfortunately, there is no much detail is available on such behavious which is incorrect.

Issue I saw got resolved with a reinstall in one and updating all device packages including MDF in second.

I would recommend to open a TAC case for further invstigation on this, or try any one of the further.

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Duong Nguyen

Go to one of the device and update the credentials, then run a DCR verification and see if it then shows up as a managed device.



Was this issue solved ?

We are facing the same strange behavior and i do not know what to do in order to solve this...


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers