cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1110
Views
0
Helpful
6
Replies
paul.parquet
Beginner

LMS 4.2.1 Inventory failed

Hello,

I can't inventory a 4507R + E / SUP7E Version 15.1.1 SG with the last version of LMS 4.2.1. Next, the extract of IC_Server.log.

I think LMS can't interpret the CISCO_ENHANCED_IMAGE_Mib

[ Tue Aug 07  11:02:11 CEST 2012 ],ERROR,[Thread-36],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,553,Exception for device 10.234.19.1 is

java.lang.reflect.InvocationTargetException

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

        at java.lang.reflect.Method.invoke(Method.java:597)

        at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:548)

        at java.lang.Thread.run(Thread.java:662)

Caused by: com.cisco.nm.xms.xdi.ags.system.CollectionFailedDeviceSensed: java.lang.NullPointerException

        at com.cisco.nm.xms.xdi.pkgs.LibInventory.ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.getImageEntryVals(ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.java:240)

        at com.cisco.nm.xms.xdi.pkgs.LibInventory.ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.populateImageAGForION(ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.java:368)

        at com.cisco.nm.xms.xdi.pkgs.SharedInventoryCatIOS.ImageAGI_CISCO_ENHANCED_IMAGE_Mib.g$eval(ImageAGI_CISCO_ENHANCED_IMAGE_Mib.java:68)

        at com.cisco.nm.xms.xdi.ags.ImageAGI.g$eval(ImageAGI.java:21)

        at com.cisco.nm.xms.xdi.SdiEngine.initAndEvalAGIs(SdiEngine.java:383)

        at com.cisco.nm.xms.xdi.SdiEngine.request(SdiEngine.java:309)

        at com.cisco.nm.xms.xdi.SdiEngine.getDevRepr(SdiEngine.java:302)

        at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:360)

        ... 1 more

[ Tue Aug 07  11:02:11 CEST 2012 ],ERROR,[Thread-36],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,571, Collection failed but sensed the device : 1

com.cisco.nm.xms.xdi.ags.system.CollectionFailedDeviceSensed: java.lang.NullPointerException

        at com.cisco.nm.xms.xdi.pkgs.LibInventory.ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.getImageEntryVals(ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.java:240)

        at com.cisco.nm.xms.xdi.pkgs.LibInventory.ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.populateImageAGForION(ImageAGI_CISCO_ENHANCED_IMAGE_HelperMethods.java:368)

        at com.cisco.nm.xms.xdi.pkgs.SharedInventoryCatIOS.ImageAGI_CISCO_ENHANCED_IMAGE_Mib.g$eval(ImageAGI_CISCO_ENHANCED_IMAGE_Mib.java:68)

        at com.cisco.nm.xms.xdi.ags.ImageAGI.g$eval(ImageAGI.java:21)

        at com.cisco.nm.xms.xdi.SdiEngine.initAndEvalAGIs(SdiEngine.java:383)

        at com.cisco.nm.xms.xdi.SdiEngine.request(SdiEngine.java:309)

        at com.cisco.nm.xms.xdi.SdiEngine.getDevRepr(SdiEngine.java:302)

        at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:360)

        at java.lang.Thread.run(Thread.java:662)

[ Tue Aug 07  11:02:13 CEST 2012 ],INFO ,[Thread-38],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.util.cache.load.MemoryCache,deleteMemeoryData,204,Going to d

elete the device from Memory Cache DCR device is 1

[ Tue Aug 07  11:02:13 CEST 2012 ],INFO ,[Thread-38],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.util.cache.load.MemoryCache,deleteMemeoryData,204,Going to d

elete the device from Memory Cache UDM device is 1

                  

Is it a bug ?

Regards,

Paul

1 ACCEPTED SOLUTION

Accepted Solutions

You need to update the device package for this issue. The packages containing fix are yet not posted to Cisco.com.

You can open a TAC case and they can assist you fix this issue by providing the necessary device pkgs to fix this.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **

View solution in original post

6 REPLIES 6
Vinod Arya
Cisco Employee

Try to increase the snmp timeout and re-run the invenotry collection job and see it goes away. Increase from 20-60 secs.

You cam increase it from :

Admin > Network > Timeout and Retry Settings > Inventory/Config Timeout and Retry Settings

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Thanks for your help, but it's not the solution I try with 60 secondes with the same error.

Seems like bug with LMS 4.2.1 # CSCub19675.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **

You need to update the device package for this issue. The packages containing fix are yet not posted to Cisco.com.

You can open a TAC case and they can assist you fix this issue by providing the necessary device pkgs to fix this.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **

View solution in original post

You're right ! So waiting for a patch...

Thanks

Paul

From the TAC (#622694933), It's a bug in the CAT4000IOS Package which will fix next week with the 4.2.2 update.

Content for Community-Ad