Showing results for 
Search instead for 
Did you mean: 

LMS 4.2 - 2960S - Software Distribution - c2960s-universalk9-tar.150-1.SE3.tar

Hello again

I am still having the same issue  - the image upgrade for our 2960S fails consequently. I have followed the BRKNMS-8641 - CiscoWorks Prime LAN Management Solution: Implementation, Configuration, and Troubleshooting - Thanks once more to Vinod for a wonderfull presentation.

After that we have started to troubleshoot this issue on the Ask the Expert session that followed the presentation but did not reached a conclusion: Link to Ask the Expert:

In resume what we tried with Vinod was to configure my 2960S swithes with this command:

no snmp-server sysobjectid type stack-oid

As he explained without this command the 2K switches are seen as stack switches by LMS. That helped further - with this LMS could see what device I was using - 2960S-PS-L but after that command was not possible to upgrade the image at all - it stopped already at step 2. Furthermore Update Inventory fails also. So I have changed my SNMP settings again and now Update Inventory works fine.

I really need some help on this because due to the introduction of EnergyWise management and on a near future of ISE we need to be able to deploy the apropriate images without being afraid of waiking up to 100 swithes which image upgrade has failed brrrrr We have several 2k switches on our network and that is one of the reasons we have purchased LMS - it would be nice to have it working

Our issue is that although LMS shows the task has a failed task for Software Distribution jobs the image gets installed with no issues - after a reload everything is ok. Have tried with different images but the one I would like to deploy now is: c2960s-universalk9-tar.150-1.SE3.tar. Would also like to add that the reload is not a part of the task has this is a production network so normally I deploy during the day and the reload takes place on low business hours.

Will be thankfull for some help or for pointing me some docs that could help on this issue.

Best regards

Isaac Alves

Vinod Arya
Cisco Employee


Seems it is a little old, but i saw it so just wanted to check if you have been able to fix this issue.

With all description, it seems like some minor issue, like time out for telnet/ssh from LMS.

Tar file will take long time to download to device from LMS and deploy. So session between
LMS and device gets terminated sometime, with subsequent reconnect failure, which can be easily addressed with increased timeout values:

Increase Read delay to 900 and telnet time out to 1000 via LMS :

Admin -> Collection Settings -> Inventory -> Edit the Inventory/Config Timeout and retry the job

Hope this problem is already addressed.



-Thanks Vinod **Rating Encourages contributors, and its really free. **

Hello Vinod


We ended opening a TAC service request and got a solution to the issue. It was not though that easy cause we worked almost a month with TAC to got this fixed. We ended up setting the telnet parameters as follows:

Telnet timeout - 700

Read Delay - 1000

Transport Timeout  - 75000

Login Timeout - 2000

Tune Sleep - 800

Delay After Connect - 1000

I got this solution as more a workaround. LMS should be able to ajust the timeouts to the device type - this timeouts work for our 2K swithes but not for the 3K - for those the only solution is trial and error.

Deploying images is just a small part of what LMS is supposed to be able to perform, but being a Cisco product and  the devices being Cisco also would expect things to go more smoother. I know that we are talking about different departments but anyway :)

Thanks for asking though.

Best regards