cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

175
Views
0
Helpful
8
Replies
Highlighted

Need some help setting up a Cisco 1921 for internet connection

I have a Cisco 1921 I am wanting to use for internet connections at home. My internet service provided is spectrum and I have a modem I want to use for this.

 

I would like to use G0/0 to go from the back of the modem, to the router. So this would be the public IP address going to the router. Then G0/1 will go to my Cisco switch, and deliver private IP address to the devices, I also need to port forward 5060 for my asterisk server. So here is what I need help with, my cisco class never taught us about connecting these to the outside world.

So, when i configure 'int g0/0' what are the appropriate commands for this interface and what are the appropriate commands for the g0/1 interface for the desired application? What are some other commands I may need to issue for this router to server as a gateway? 

8 REPLIES 8
VIP Mentor

Re: Need some help setting up a Cisco 1921 for internet connection

Hi
You could put the modem in bridge mode and use the public ip address on the Cisco interface facing the modem , making the modem dumb basically , then set a default route out that interface and also set NAT overload on the router to break out

example in this

https://www.yourictmagazine.com/howtos/434-basics-to-configure-a-cisco-router-to-connect-to-internet.html

Re: Need some help setting up a Cisco 1921 for internet connection

Cool! Is the ISP address the public IP address provided by the ISP, or is that the modem address?

(2. ISP Addresses: [IP Address: 192.168.23.11 )?

 

What is this address?

ip name-server 208.67.222.222

 

What address would this be

ICT(config)# ip route 0.0.0.0 0.0.0.0 192.168.23.1

 

VIP Mentor

Re: Need some help setting up a Cisco 1921 for internet connection

Hi
Yes if the modem is in bridge state it pushes operations back to the Cisco router so you would put the public ip there and make sure the ip nat outside is configured on the interface and correct in global config like the doc or you wont be able to reach anything external as no translations

Re: Need some help setting up a Cisco 1921 for internet connection

Here is my config does this look okay? I italicized the parts of the config I am not sure of. I updated this as per my topology. I also attached a crude topology to make a bit more of sense of it

topology.png

Router>en
Router# config t
Router(config)# hostname ICT
ICT(config)# enable password express
ICT(config)# enable secret express
ICT(config)# ip name-server 8.8.8.8 (DNS?)
ICT(config)# line console 0
ICT(config-line)# password express
ICT(config-line)# login
ICT(config-line)# exit
ICT(config)# line vty 0 4
ICT(config-line)# password express
ICT(config-line)# login
ICT(config-line)# exit
ICT(config)# interface Ethernet1/0
ICT(config-if)# Description LAN
ICT(config-if)# ip address 10.0.161.0 255.255.255.0
ICT(config-if)# ip nat inside
ICT(config-if)# no shutdown
ICT(config-if)# exit
ICT(config)# interface FastEthernet0/0
ICT(config-if)# Description Broadband Internet
ICT(config-if)# ip address 192.168.23.11 255.255.255.0 (address of modem?)
ICT(config-if)# ip nat outside
ICT(config-if)# no shutdown
ICT(config-if)# exit
ICT(config)# interface FastEthernet0/0
ICT(config-if)# Description Broadband Internet
ICT(config-if)# ip address 79.79.79.79 255.255.255.0 (Public IP address?)
ICT(config-if)# ip nat outside
ICT(config-if)# no shutdown
ICT(config-if)# exit
ICT(config)# ip nat inside source list 1 interface FastEthernet0/0 overload
ICT(config)# ip route 0.0.0.0 0.0.0.0 192.168.23.1 (address of modem?)
ICT(config)# access-list 1 permit 10.100.10.0 0.0.0.255 (what address is this?)

VIP Mentor

Re: Need some help setting up a Cisco 1921 for internet connection

ok that modems is not in bridge mode if it still has an IP address like that , does it support bridge mode , you should be able to access it and usually there is a tab you set ,
if its this modem here is a link to it , when its in bridge mode the ISP Ip will be on the Cisco interface , it makes the modem dumb basically doesnt understand IP just passes traffic through

https://my.eastlink.ca/customer-support/internet/wifi/configure-my-modem-for-bridged-mode-motorola-sbg6580

Then remove this section

ICT(config)# interface FastEthernet0/0
ICT(config-if)# Description Broadband Internet
ICT(config-if)# ip address 192.168.23.11 255.255.255.0 (address of modem?)
ICT(config-if)# ip nat outside
ICT(config-if)# no shutdown
ICT(config-if)# exit


ip name-server not really required , just set 8.8.8.8 user pcs as DNS

That access list maps to your LAN subnet for NAT , it must be the same so ....
access-list 1 permit 10.0.161.0 0.0.0.255

should work then

Re: Need some help setting up a Cisco 1921 for internet connection

This modem does pass the public IP. I think it gives it self that address so you can access the web-UI

 

I have a Motorola MB8600

VIP Mentor

Re: Need some help setting up a Cisco 1921 for internet connection

Oh ok does it support NAT or is its only function to have a mgmt ip address , you might want to turn it off if your going to do it on Cisco side

This doc would be better suited to your setup if the bridge option is not available , basically same commands only on interface facing modem you use ------ ip address dhcp

Its got a clear config setup in it and topology

https://www.cisco.com/c/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.html

How to Configure a Cisco Router Behind a Non-Cisco Cable Modem

Re: Need some help setting up a Cisco 1921 for internet connection

Its does not have NAT from what I see. There are not options to disable NAT. I plugged a device into the modem and it gets the public IP address. 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards