cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
505
Views
0
Helpful
8
Replies
motiar
Beginner

Nexus 5596 Switche keep droping the traffics

Hello expert,

I faced the following problem: I habe some catalyst Switche, connected redundantly to vPC Nexus 5596 Switche and the Nexus Switches are connected redundantly to Core-Switche, as you can see the Topology and relevant outputs of configurations.  

 

Do you have any suggestion, why the Switche are keeping droping the traffics? Will be thankful.

 

Best regards

Motiar

 

 

 

8 REPLIES 8
MHM Cisco World
Rising star

If you allow VLAN through vPC peer link then you need 
VPC under the ether channel toward the Non-Nexus SW.

Hi,

Thank you for your response. The vPC is configured under etherchannel toward Non-Nexus SW correctly and I think this is not the case. Only few switches are droping traffics, expecially during peak hours.

 

Do you have any other suggestion?

Regards

Motiar

MHM Cisco World
Rising star

Non-vPC SW Connect to vPC...
the STP is handle in way that make non-vPC SW use one link toward the primary vPC peer only, other is BLK.

I know the vPC must appear as one SW but this for only vPC SW not for non-vPC SW.

now your design is depend on BW of other link but use one make link drop frame. 

what solution?

pseudo-information make load balance and hence the STP not BLK the link but instead BLK some VLAN in link toward Primary and BLK other VLAN in link toward Secondary.

Georg Pauwen
VIP Expert

Hello,

 

post the port channel configuration of the other switch (Nexus 5596 SW-02) as well. Also post the output of:

 

sh interfaces x

 

where 'x' are the physical member interfaces of the port channel.

Hi Georg,

here are the configurations: 

Note: Nexus-5596-SW-02 has vPC role secondary and Nexus-5596-SW-01 with vpc role primary.

 

Nexus-5596-SW-02# sh port-channel summary
1 Po1(SU) Eth LACP Eth1/3(P) Eth1/4(P)
5 Po5(SU) Eth LACP Eth1/1(P) Eth1/2(P)
80 Po80(SU) Eth LACP Eth1/23(P)
81 Po81(SU) Eth LACP Eth1/24(P)
82 Po82(SU) Eth LACP Eth1/25(P)
83 Po83(SU) Eth LACP Eth1/26(P)

Note: po1 = peer-link to Nexus-5596-SW-01
Po5 = port-chanel to CORE-SW
po80-83= behaind Nexus-5596 Switch, Non-Nwxus-SW, with packet droping
---------------
Nexus-5596-SW-02# sh run int po1
interface port-channel1
description Nexus-5596-SW-01 VPC-Peer
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan XXX,XXX,XXX..............
spanning-tree port type network
spanning-tree guard loop
vpc peer-link
------------------
Nexus-5596-SW-02# sh run int Eth1/3

interface Ethernet1/3
description Nexus-5596-SW-01 eth1/3
switchport mode trunk
switchport trunk allowed vlan XXX,XXX,XXX...............
channel-group 1 mode active

 

Nexus-5596-SW-02# sh run int Eth1/4

interface Ethernet1/4
description Nexus-5596-SW-01 eth1/4
switchport mode trunk
switchport trunk allowed vlan XXX,XXX,XXX..............
channel-group 1 mode active
------------------

 

Nexus-5596-SW-02# sh run int po80

interface port-channel80
description to Non-Nexus-SW-80
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 110,310-312,480
spanning-tree guard loop
vpc 80

 

Nexus-5596-SW-02# sh run int Eth1/23

interface Ethernet1/23
description Non-Nexus-SW-80 eth0/48
switchport mode trunk
switchport trunk allowed vlan 110,310-312,480
spanning-tree guard loop
speed 1000
udld aggressive
channel-group 80 mode active

-------

 

Nexus-5596-SW-02# sh run int po5

interface port-channel5
description To CORE-01 & CORE-02
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan XXX,XXX,XXX..........
spanning-tree port type network
spanning-tree guard loop
vpc 5
---
Nexus-5596-SW-02# sh vpc role

vPC Role status
----------------------------------------------------
vPC role : secondary, operational primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:65
vPC system-priority : 32667
vPC local system-mac : 8c:60:4f:1a:3b:c1
vPC local role-priority : 32667
---------------------

Nexus-5596-SW-01# sh vpc role

vPC Role status
----------------------------------------------------
vPC role : primary, operational secondary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:65
vPC system-priority : 32667
vPC local system-mac : 8c:60:4f:09:f0:41
vPC local role-priority : 1

 

Hello,

 

also post the output of:

 

sh interfaces x

 

where 'x' are the physical member interfaces of the port channel.

 

So we can see what traffic is dropped on the interfaces.

Hi Georg,

attached you are getting the outputs of "show interface X"

 

Regards

Motiar 

MHM Cisco World
Rising star

Friend are this issue Solved ?

Content for Community-Ad