Showing results for 
Search instead for 
Did you mean: 

PI 2.0 can't check for updates within Prime


When I click "check for udpates" I immediately get an error saying

"There was a problem connecting to from the Prime Infrastructure Server. Alternatively you can go here, enter 'Prime Infrastructure' for the product name, and click on Find button. Download the latest update file and upload it to your server using the 'Upload Update File' button. Make sure the selected update is greater than your Prime Infrastructure instance version.

Prime Infrastructure Version: 2.0.10"

Anyone else get this?

I can ping from the server itself so it has connectivity.


Marvin Rhoads
VIP Community Legend

Does your environment use a proxy server for web requests? If so, that needs to be configured manually in Prime.

No proxy server here.  As I mentioned the box can get out to the internet.  It worked once before, but never again after that.

Ugh - it looks like it may be broken again - something similar to this happened about a year ago with the LMS update process. I just checked two different PI 2.0 installations in completely separate networks and am getting the same error.

I know Cisco has been reconfiguring the back end filesystems of a lot of the sites - I'd be willing to bet that the site URL hard-coded into PI 2.0 when you click that button has been moved.

I suggest you open a TAC case to alert them of it. When it happened before they were about a month fixing the problem.

I would say it has been over a month now since I first started noticing the error.  The last update I did when it worked was mid december.  I don't have support on my PI install.  Are you able to open a case?


do you have de last update pach and device pach?

I got the same problems and I am running up to date PI2 with Device Update 4.0

Marvin Rhoads
VIP Community Legend

The bug I mentioned above shows status of Fixed in BugSearch tool but the download link they provide isn't right. The PI 2.0 patch location doesn't show any new updates.

So for now you'll have to continue manual download.


Well this bug still appears to be in Prime 2.2 and 2.2.1 as well!

Bruce Winters

Ditto here same issue. Where is the upload local file button?

Sent from Cisco Technical Support Android App

Marvin Rhoads
VIP Community Legend

I found out it's a confirmed bug:

Unable to connect to for software update from PI 2.0


The workaround for now is the manual process. That is, download the update file(s) from to your local PC. Here's the link to the device updates and patches:

Then, in PI, go to Administration > Software Update and choose the "Upload Update File" button. That should lead you to the screen shown below (click to enlarge). After it uploads, select the file and click the Install button.


I am trying to upload the 2.1.2 patch using the manual upload option.  I click the browse button to select the 2.1.2 ubf file from my local machine, but when I click OK to upload the file, I get an error message that says "No file has been selected."  Any ideas why this doesn't work?  We are not using a proxy server in our environment.

I'd suggest trying with a different browser. I uploaded and applied the patch just fine using Chrome.

Gotta love (hate) IE.  Safari to the rescue!!  Thanks Marvin!

You're welcome.

Please take a moment to rate helpful posts.

Content for Community-Ad