cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1534
Views
0
Helpful
2
Replies

PPPoE configuration in packet tracer

Tomizius
Beginner
Beginner

Hello
I'm just trying to configure a setup with a PPPoE-Server and a PPPoE-Client with the packet tracer.

Server and client are connected trough ethernet.

The authentication of the client should be with chap or pap.

The client will get the IP address automatic from the server trough IPCP.

 

So far I configured following at the client:

 

interface GigabitEthernet 0/0
pppoe enable
pppoe-client dial-pool-number 1
exit
 
interface Dialer 1
encapsulation ppp
mtu 1492
ip address negotiated
dialer pool 1
ppp authentication chap
ppp chap hostname cisco
ppp chap password csico
exit
 
ip route 0.0.0.0 0.0.0.0 dialer 1
 
Here we go for the server:
 
username cisco password cisco
ip local pool PPPoE-Dialers 84.3.98.2 84.3.98.6
interface Virtual-Template 1
ip unnumbered GigabitEthernet 0/0
peer default ip address pool PPPoE-Dialers
ppp authentication chap
exit
 
vpdn-group GROUP
accept-dialin
protocol pppoe
virtual-template 1
 
bba-group pppoe global
virtual-template 1
exit
 
interface GigabitEthernet 0/0
pppoe enable
ip address 84.3.98.1 255.255.255.248
 
So far so good, after I turn on the interfaces GigabitEthernet on the server and client the client start sending PPPoED with the code 0x09 – PADI (PPPoE Active Discovery Initiation).
 
But the server is not responding to the PPPoED with anything.
I also can provide some more information about my config, just tell me what you need.
 
Looking forward if someone can help
 
Regards Thomas
2 Replies 2

Martin L
VIP Advisor VIP Advisor
VIP Advisor

 

this could be PT limitation; after all, it is just a sim written to behave like real IOS with lots of features missing or not working exactly like real IOS (simplify in PT).

Have you tried this config in GNS3 or CML ?  You can use free online CML via Snadbox. 

 

Regards, ML
**Please Rate All Helpful Responses **

Tomizius
Beginner
Beginner

I know what you mean, that the PT is limited, but it should be possible to configure PPPoE with PT.

Unfortunately I'm not familiar with GSN3 or CML.

 

Is there for real noone, who has ever configured PPPoE with PT?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers