Showing results for 
Search instead for 
Did you mean: 

Prime Infrastructure 1.2 - Unable to do config archive of WLC

Christian Haller

Hi everyone

I'm trying to do configuration archiving in Prime Infrastructure 1.2 with a 5508 WLC (7.4).

The job always fails (Admin -> Background Jobs) with the following error (see attachement):

"SNMP: Failed to establish SNMP connection xxxx - Cause: Device is Unreachable. Check the ReadOnly community string."

I double checked the SNMP credentials, they do match.

For testing I also added a Public community just for the PI. Same result.

Am I missing something?

Is this not intended for Wireless Controllers?

Thanks in advance.



14 Replies 14

J. Aske

The release notes for wlc 7.4 says you need PI 1.3

Sent from Cisco Technical Support iPad App

Try using a RW community string....

Hi Rob

Thanks for the suggestion.

But Prime and WLC already share a RW community, since it is used for the main communication for management traffic.

Anyway, I don't see the possibility to change the community for this scenario?

Do you know, where to change it?


Hi Jeff

Thanks, I must have missed that in the release notes.

It really might be the case that 1.3 is needed, altough this has been the first problem we ran into.



Vincent Duprez

Dear all,

I have the same issue with PI 1.3 and WLc 7.4.

Background task (controller configureation Backup) is successfull but I don't have any archive for my controller.

While trying to perform a manual backup I'm receiving this error message :

"SNMP: Failed to establish SNMP connection xxxx - Cause: Device is Unreachable. Check the ReadOnly community string." and telnet failed

even if configuration archive is suppose to be made in SSh first ?

any idea ?

Hi Vincent:

Yes, the config archive should be done over SSH version 2 (version on the controller).  The use of Read Only communities with Prime Infrastructure/NCS/WCS is also not recommended as so many functions require ReadWrite access to work as expected.

As well, now that you're on Prime Infrastructure, be sure to check out and install the Update 1 patch for Prime Infrastructure (filename PI_1.3.0.20_Update_1-12.tar.gz).

Release Notes for Update 1 for Cisco Prime Infrastructure

The issue resovled, thank you for advice.

Hi Rollin,

How do you specify SSH version 2 to perform the config archive?



I have the same issue.

I am running PI 1.3 and upgraded the WLCs from 7.2 to 7.4, and ever since config archive has been failing:

"SNMP: Failed to establish SNMP connection xxxx - Cause: Device is Unreachable. Check the ReadOnly community string."


Try to enable SNMP version1 on the WLC.

I experience similar Issue and appling this WA now works

Yep, enabling SNMP v1 fixed the issue. Thanks v.avagliano!!!

Did you log a TAC case and get this WA from Cisco or just happen to try it and it worked?

I have read message about wrong SNMP auth and I play on that configuration...

Thank you v.avagliano and Brad! I tried a bunch of config changes to find out why my config backups were failing. Enabling SNMPv1 did the trick and now I can track the bug...I'm guessing v2.0 release which is less than 2 weeks out.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: