Showing results for 
Search instead for 
Did you mean: 

Prime Infrastructure (2.0) utilization report on port group possible?

dean holroyd
Level 1
Level 1


I want to create an interface utilization report for a specific port group in PI, but can't see how to do that in the report setting. You only seem to be able to select a specific device or site rather than port group. Is it possible? Also, is it possible to put that on a dashlet?

thanks for your help

9 Replies 9

Mahabir Prasad
Level 1
Level 1

Hi Dean

You can do that as below:

1. Create port group: Go to Design>Management tools>Port grouping. Here on left side click on all port and right side it wil show you all ports available from all devices managed in PI. From here you can select different ports and make your own port group under 'user defined' group.

2. Now go to Design>Monitor configuration>Features>Metrics>Interface Health. Here you can define which parameters you want to monitor for port group/interfaces like inpututlization, outpututilization, inerrors, outerrors etc and save as new template.

3. Now go to Deploy>Monitoring deployment and select template you created and then click on deploy. Now on 'Template Deployment' popup window select radio button 'Port Groups' and select your defined port group and click submit.

4. Now you can go to Home>Performance>Network Interface tab and can monitor interface statistics selected in template.

I hope you looking for this.

If you find this post helpful then rate it.



Thanks for that Mahavir

Yes, I worked that out a little while ago, and can now see interface utilization by port group on the Performance > Network Interface page. I do have another question however (well two)....

I wanted to add graph over time for the utilization to the detail dashboard, but nothing shows up, even though I see the utilization in the network interface page, so I'm sure the monitoring is deployed. Why is the data missing from the graphs?

Also, I wanted to see interface packets per second graphs, but see that is not part of any default template, so I created a customer SNMP template from the IF-MIB to do this, but I can only deploy that against sites/devices or a list of interfaces, and not port groups. Why can't I deploy a customer SNMP template against a port group?

thanks for your help

Hi Dean

Regarding 'Interface Tx and Rx Utilization' dashlet not showing any data, there was an internal bug even before product release but it is showing as fixed in the current build. But i can see problem is still there. This need to be checked with BU.

I will check with BU for resolution but this can take time.

Regarding Port group not showing while deploying custom snmp template this looks like not available and an echancement request can be filed for it. Will also check with BU on this.



Thanks Mahavir

I really appreciate you taking the time to answer the questions. I would appreciate if you could point me in the direction of a couple more answers. I am trying to receive syslogs on the PI server, but for some reason I can't see anything. Is there something particular I have to enable to see syslogs? I read that it could only receive certain levels, but I have tried all and don't see anything.

Also, can Cisco PI support sampled netflow (v9) data? We have an ASR9000 that is sending around 200K flows, so PI won't scale to that according to the docs. We have an Arbor set up, which receives and converts the sampled netflow data (1024:1), but can Cisco PI do the same thing, or will it show at 1000 times less than the real data rates?

Again thanks for your help

just a quick note regarding the syslogs..

It seems that you are sending syslogs with a facility of "local0" which could be the cause of your problem. Cisco devices typically send syslogs with a facility of "local7" and I assume the syslog receiver of Cisco PI filters on the facility. AFAIK, only some Cisco security devices use a facility other then local7.

thanks Martin

I tried every facility and every level, but nothing was seen by PI


Hi Dean,

Below thread could help you (this issue same as PI 1.3)


Level 1
Level 1


I am getting all  dashlets. But I cant genertate a TX/rx report. Dashlet displays  monitoring but reporting launch pad does not show up anything for  reporting the link.



Hello All,


I am facing the same issue that the interface utilization not showing up in prime infrastructure 2.0??. Any solution for this ??


Thanks in advance


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: