Showing results for 
Search instead for 
Did you mean: 


Prime Infrastructure 2.2 can't delete file name too long

I'm trying to delete older application backups in the CLI, and it says I can't because the filepath is too many characters.

Ex. prime/admin# delete disk://defaultRepo/prime-150916-0330__VER2.
% param string too long detected at '^' marker.

So, how do I delete these files?


i succeed using Long Path

i succeed using Long Path Tool


How can you use the LONG Path

How can you use the LONG Path tool to delete the too long files in Prime 2.2


I have the same problem with

I have the same problem with you, cannot delete the too long backup data,  and I cannot find any "rename" or "mv" command to change the files name shorter....    how was your solve such issues?


If you use the "root" command

If you use the "root" command, after enabling it with "root_enable", you can go into the underlying Linux shell.  From there, go to the /localdisk directory.  Change to whichever directory the file is in, then do a "rm filename".  Just ran into the same issue, and this worked.


Hi Jason, Appreciated your

Hi Jason, Appreciated your help,  works for me too....

Long PathTool is a software

Long PathTool is a software that will let you easily delete, copy or rename long path files.


Note that the "root" command

Note that the "root" command has been changed to the "shell" command as of PI 3.0.

A couple of people have mentioned using the Long Path Tool. If there is a way that you know of to access the file structure within Prime remotely via Long Path Tool (or any other way,) please share those steps.  To my knowledge, it isn't possible, but would love to be wrong on this.


Try using Long Path Tool as

Try using Long Path Tool as it works better.


“Long Path Tool” is very

“Long Path Tool” is very helpful for this error !
You can use to solve this problem

Long Path Tool help me a lot when i have an issue like file deleting or renaming the file. Also good to use if file name and file extension is too long.

I used to have similar problems too, but after using "long path tool" everything was solved. Try this software and you would be glad you did.

Long path tool is the very

Long path tool is the very good program for error, unlock solution.
Try it and solve your problem.
I used long path tool and I solve my error, unlock problem solution.


Long Path Tool is the perfect

Long Path Tool is the perfect utility that can solve all the long path issues. Download this software online.


Do not use other programs use

Do not use other programs use SSH, Root acces and Linux commands.

xprime/admin# root_enable
Password :
Password Again :

Root enabled

xprime/admin# root
Enter root password :
Starting root bash shell ...

ade # cd /localdisk/defaultRepo/

ade # ls -lh
total 3.1G
-rw-rw-rw- 1 root gadmin 3.1G Jul  9 03:50 xprime-170709***********************.tar.gpg

ade # rm xprime-170709***********************.tar.gpg



Thanks mate,

Thanks mate,

It worked for me, after few hours wasted I run into your solution and saved my day


Re: Do not use other programs use

This worked for me. Thanks!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards