cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
376
Views
0
Helpful
5
Replies
Beginner

Prime Infrastructure 3.3 HA registration fails

Hello,

 

I am having trouble registering my 2 PI virtual appliance servers in HA, the message is:

"Error: Failed to perform HA registration as the network interface configuration in the Primary and Secondary are not similar. "

 

This started after the upgrade to PI 3.3, HA worked just fine on 3.1.7 before, and I can't find this error explained anywhere.

Does anyone have any idea what this means and how to solve it?

 

Thanks in advance.

Everyone's tags (1)
5 REPLIES 5
Cisco Employee

Re: Prime Infrastructure 3.3 HA registration fails

Usually you see this error if the netmask/gateway info do not match for the same subnet. How did you upgrade? Was it in-place or did you restore from an appliance backup? The latter should have saved all info for network. If you built a new machine and restored from an application backup, you could have changed the settings.

Beginner

Re: Prime Infrastructure 3.3 HA registration fails

The 2 instances are not in the same subnet. The upgrade to 3.3 was performed in-place for both. The only thing that seems different is that the primary has interface GigabitEthernet 1 and the secondary has GigabitEthernet 0 with IP address configured - but I haven’t found a way to change this.

Highlighted
Cisco Employee

Re: Prime Infrastructure 3.3 HA registration fails

You should be able to change the configuration from the command line. Ye olde conf term will get you to the low level config info. You can change all the interface info you would expect from there.

Beginner

Re: Prime Infrastructure 3.3 HA registration fails

What I meant was that i saw in a guide somewhere that the HA registration checks for eth0 speed, and the primary instance uses eth1 and i wasn’t able to configure eth0 on it (didn’t try to delete the interface and configure eth0) - this made some sense considering the error text.

Beginner

Re: Prime Infrastructure 3.3 HA registration fails

Hello, 

I have exact same issue with PI 3.6. Have you found any solution to this problem?

 

Thanks

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards