cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3525
Views
20
Helpful
8
Replies
Highlighted
dal Participant
Participant

Prime Infrastructure upgrade from v3.0 to v3.1 fails

Hi.

I tried to upgrade our PI to v3.1 today, but it fails:

Pre-install step failed. Please check the logs for more details.

And the log says:
Install initiated with bundle - PI-Upgrade-3.0.X_to_3.1.0.0.132.tar.gz, repo - defaultRepo
Stage area - /storeddata/Installing/.1461331009
Getting bundle to local machinelocal copy in of PI-Upgrade-3.0.X_to_3.1.0.0.132.tar.gz requested
Got bundle at - /storeddata/Installing/.1461331009/PI-Upgrade-3.0.X_to_3.1.0.0.132.tar.gz
Unbundling package PI-Upgrade-3.0.X_to_3.1.0.0.132.tar.gz
Unbundling done. Verifying input parameters...
Manifest file is at - /storeddata/Installing/.1461331009/manifest.xml
Manifest file appname - NCS
Manifest file pkgtype - CARS
Verify dependency list -
Verify app license -
Verify app RPM's
No of RPM's - 1
Disk - 50
Disk requested = 51200 KB
More disk found Free = 462446592, req_disk = 51200
Mem requested by app - 300
Mem requested = 307200
Found MemFree = MemFree:         54764 kB
Found MemFree value = 54764
Found Inactive = Inactive:      4894892 kB
Found Inactive MemFree value = 4894892
Sufficient mem found
Done checking memory...
Verifying preinstall zip...
Verifying RPM's...
Verifed all RPM's in bundle and manifest
Verifying postinstall zip...
Executing preinstall steps...
Executing preinstall script preinstall.sh from preinstall.zip
App (NCS) Preinstall script preinstall.sh failed;  
error message: Pre-install step failed. Please check the logs for more details.
Error while Installing - Application bundle: PI-Upgrade-3.0.X_to_3.1.0.0.132.tar.gz  Repository: defaultRepo  ErrorCode: -635

What does that mean?


Memory and disk space seems to be sufficient

PI v3.0 has all patches and device packs already in place.

Any tips?

Thanks.

8 REPLIES 8
Highlighted
Hall of Fame Guru

What platform are you using?

What platform are you using?

Are you doing the installation from a VMware console session if it's a VM?

Did you clear your defaultRepo of any existing backups first?

dal Participant
Participant

Never mindIt is a VM, so when

Never mind
It is a VM, so when I used the VMWare console, I saw the real error: NCS had to be stopped manually first.

After that, the upgrade worked fine.

Thank you.

Highlighted
Beginner

I am late to this party. I am

I am late to this party. I am getting the same error message when trying to upgrade to 3.1. When you say you manually stopped NCS, do you mean "NCS stop"? I am running that and still am unable to get past this error.

Highlighted
Beginner

I had this error too,

I had this error too, jeffyplezia. Doing the upgrade from the VM console sorted it. When attempting it from an SSH session I got the pre-install step failed error. 

Highlighted
Cisco Employee

A bit late to the party

A bit late to the party myself, but this is actually expected behavior.

The PI 3.1 upgrade involves upgrading the OS as well, which is why the process cannot be done from a regular SSH session.

This is briefly documented in the PI 3.1 Quick Start Guide below. Look at Step 11:

http://www.cisco.com/c/en/us/td/docs/net_mgmt/prime/infrastructure/3-1/quickstart/guide/cpi_qsg.html#pgfId-136237

Cheers,

Luis

Highlighted

I'm on 3.0.3 trying the PI

I'm on 3.0.3 trying the PI-Upgrade-3.0.X_to_3.1.0.0.0.132.tar.gz upgrade, and getting the same error ON the console. 

How do I get the error logs to share with TAC?

Highlighted

ona prev call I remember

ona prev call I remember logging into ROOT, and i did a more install.log and see: 

Installing libgcc-4.1.2-54.e15.x86_64

warning: libgcc-4.1.2-54.e15: Header v3 DSA signature: NOKEY, key id xxxxxx

does that mean that the problem is with this file? Do I just need to do a backup and restore on a parallel VM?

Highlighted
Beginner

Hi,

Hi,

Please, could you say to me the name of the log file in which I can find the information related to the upgrade proccess (and the path of these files)?

thanks

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards