cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10942
Views
20
Helpful
8
Replies
ciscoworlds
Enthusiast

Prime Infrastructure web login issue

Hi;

I am about to test the Prime Infrastructure 3.1 but cannot login to the web interface, because it doesn't accept my username and password that I determined with "setup" command. I can establish ssh to it with root username and password but not web interface. 

this is the output of the "ncs status" command:

.

==================================

cisco-prime/admin# ncs status
Health Monitor is stopped.
Database server is running
FTP Service is running
TFTP Service is running
Matlab Server is running
Matlab Server Instance 1 is running
NMS Server is running.
Plug and Play Gateway is running.
SAM Daemon is running ...
DA Daemon is running ...

==================================

.

what can be the cause of the problem? even I used "ncs password root password *******" command but was unsuccessful. it unlocked me after repeatedly denying me due to invalid username/password. 

8 REPLIES 8
marce1000
VIP Advisor

 - Following comparision from my installation Healt monitor shouldn't be stopped , but running ; I don't know the wether this relates to your problem; but I guess it should be fixed; I don't  have knowledge details on this, currently; perhaps a reboot ?

M>

Hi;

I ran "ncs stop, ncs cleanup, ncs start" commands respectively and again ran the "NCS status" command:

.

===================================================

cisco-prime/admin# NCS status
Health Monitor Server is running. ( [Role] Primary [State] HA not Configured )
Database server is running
FTP Service is running
TFTP Service is running
Matlab Server is running
Matlab Server Instance 1 is running
NMS Server is running.
Plug and Play Gateway is running.
SAM Daemon is running ...
DA Daemon is running ...

.

===================================================

but again I cannot login to the web interface with "admin" username and my password. it says "Invalid Username and Password". I changed the pass word with "NCS password root password" again but was unsuccessful. is the web username "admin" by default? because I cannot see it anywhere. 

I searched the net and found lots of people have experienced this problem, but at the end, no one managed to give any answer. 

I appreciate any Cisco internal guy to help us with this really silly problem. 

>but again I cannot login to the web interface with "admin" username and my password. it says "Invalid Username and Password". I changed the pass word with "NCS password root password" again but was unsuccessful. is the web username "admin" by default? because I cannot see it anywhere. 

      1) To avoid confusion "NCS password root...." sets the password for the root account and not admin (the latter is done in the running-config; -> hope that's clear); I think both accounts should work for web logon.

      2) To avoid password-confusion; if you are using special characters try, for testing, with a plain password such as abc2000

      3) If still no go; logon via ssh as user admin; then issue the shell (type 'shell') command ; followed by the sudo -s command; you will now be a unix-root-privileged user on the system

         3.1) issue  tail -f /var/log/httpd/error_log ; then do a web logon attempt and see what appears in this file; repeat the same cycle for access_log (in the same directory).

M.

 I reinstalled the whole VM and setup it from ground up. this time I accidentally test the username"root" and my password for web interface that I setup during the initial setup mode and it was accepted. don't know the reason. there is no such thing in anywhere in Cisco doc. 

username: root

password: the password you have entered during the initial "setup mode" as the answer to the "Enter Web Interface Root Password" question. 

I hope Cisco guys update their doc site to include this simple credentials on their help docs ASAP!

Thanks for coming back and letting us know - I had the same issue and amongst all the comments saying to restart services I found your comment.

Using 'root' as the Username worked.

Hi All, 

I am unable to login to Cisco Prime web page . Could you please anyone let me know what might be the error.

I am getting the error as "this site can't be reached". i am able to ping and tracert the IP.

 

Ajay

If you have "this site can't be reached" check first  -  ncs status...

For me ncs service is down.

I managed to resolve similar issue by running the following command to reset PI root GUI password

primeabc/admin# ncs password root password acbxyz123<<<<(your password)