cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1099
Views
0
Helpful
13
Replies
Alex Preston
Beginner

Private enterprise MIBs don't allow configuration with SNMP set commands

I faced an issue when I try to set the value of some Cisco Enterprise MIB Objects via SNMP set in Docsis network with Cisco EPC3008 data modems. Some private enterprise MIBs don't allow configuration using SNMP set commands. Although it must be configurable. SNMP walk just return the default values, but I can't change them.

In particular, I can't set the values for these OIDs:

saCmMtaCliAccessType.0 disable(0)
saCmMtaCliAccessInterface.0

 

How it can be configured then?

13 REPLIES 13
marce1000
VIP Advisor

 

     - Can it be done manually with the snmpset command, if not which error is then  returned ?

 M.

Alex Preston
Beginner

I tried set it use SnmpB MIB browser. When query snmpget  command, it return values

 
--- SNMP query started ---
1: saCmMtaCliAccessType.0 disable(0)
--- SNMP query finished ---
 
---- SNMP query started ----
1: saCmMtaCliAccessInterface.0
---- SNMP query finished ----
 
but when do snmpset, it just show timeout:
 
---- SNMP set started ----
Timeout
 

 

           - Try a command line version of snmpset and use verbose mode , to get more info's

 M.

tried command line version,

$ snmpset -v1 -c private 192.168.100.1 1.3.6.1.4.1.1429.78.1.1001.1.0 i 1
Timeout: No Response from 192.168.100.1

 

didn't find a verbose option though. -DALL returns too much info, not fit completely in terminal window.

 

 - Check the snmp-rw credentials in the device configuration. Make sure they match the (rw) community you are using in the snmpset command , and or there is no blocking by any snmp-related access lists.

 M.

I'm checking. I managed to save snmpset verbose output to a file.

snmpset -v1 -c private -DALL 192.168.100.1 1.3.6.1.4.1.1429.78.1.1001.1.0 i 1

I also tried this command with community name "public", same result.

You simply need to know the rw-snmp-community the device was configured
with.

M.

where it specified, in device Snmp Agent code? From snmpwalk output, its "public" (at the end of mib). I just tried snmpset with other OIDs that have read-write access, got the same result, they all show  Timeout: No Response from 192.168.100.1 Possibly, it could be network addressing limitation, or feature that prevent setting object values from within a private class C network IP address range (192.x.x.x), allowing set values only from class A network IP address range (10.x.x.x).

 

 - Finding out the correct rw-community is still the main task here. For a linksys device you usually enter the system configuration (web interface) and go to  Configuration > System Management >SNMPReview current settings and apply accordingly.

 M.

snmp Community Name is "public", as shown in mibs. Its data cable modem, there is no feature allowing system configuration from web interface.

 

 - The latter statement is as good as false. Any system providing snmp-write capabilities will have an option to set the correlated snmp rw community. The 'public' mentioned in the mib  is a documentaion-default. Further more any good network-manager will have changed this to prevent tampering with the device.

 M.

well, at least for read-only (GET) operations snmp community name of the agent ("public") is correct? It works and returns values. Does the verbose output contain any clues?

 

 - public is indeed the default read-only community needed for GET-operations. The default for rw-community could be private (needed for snmpset). You may try that. If it works then that is a security risk and the device should be configured with none-standard community names w.r.t. snmp access.

  M.