Showing results for 
Search instead for 
Did you mean: 

Problems with DHCP options 43 and 120 relay trough Cisco ASA (For Lync Phones)

Level 1
Level 1

We are trying to set up the correct options for Lync Phones, and we are using a windows server 2008 Standard as a dhcp server.

The DHCP server is located on one VLAN, and have been running for many years, so the ip delegation works perfectly.

I see that all the added options are correct. Correct CertPath, correct servernames and correct portnumber.

But i cant seem to get the DHCP ACK with the sip parameters (option 43 and 120) to traverse our Cisco ASA.
If i capture the traffic, i see the inform message going from the client, and its being forwarded across the asa to our DHCP server.

And i also see the ACK, being sent from our dhcp server with the option 43 and 120 set back towards the client. But the packet is not being picket up on the client machine.

I capture with allow access lists. (ive also checked deny access lists, but they doesnt pick up any denied packets).

if i run: debug dhcp event (and packet), i get this:

DHCPD: setting giaddr to

dhcpd_forward_request: request from CLIENT.MAC.ADDR forwarded to

DHCPD/RA: Punt --> ClientMachine/17152 to CP

DHCPRA: Received a BOOTREPLY from interface 11

DHCPRA: dhcp_relay_agent_receiver:can't find binding

When i try to run the: Dhcputil.exe -emulateclient      (MS tool to check the DHCP option 43 and 120)

Info:     = The interface the client machines resides on.    = Our DHCP server.

Ive also checked with: show dhcpd binding all

This command never show any bindings, even when its forwarding a valid dhcp request.

Does anybody have any tip for something i can try?

Regards, Thomas

3 Replies 3

Maria Lilyakova
Level 1
Level 1

Hello, Thomas.

We met the same problem a few days ago. I see nobody answered, but maybe you solved this problem by yourself.

Regards, Maria

We are also having this issue. Has anyone got any information on what the cause may be?

I have dealt with Cisco and they have acknowdeldge there is a bug in version 8.6(1) and recommend updating to 9.0(3), or to 9.1(2).

We are running a ASA5515 with 8.6.1

This is from their bug tracker:

ASA - dhcp relay - bindings are not created for DHCP Informs
When acting as a DHCP relay, ASA doesn't forward the DHCP ACK from the dhcp server in response to a Relayed DHCP Inform. The output of 'debug dhcprelay packet' may show the following:

DHCPRA: dhcp_relay_agent_receiver:can't find binding

This is because the ASA did not build a DHCP Relay binding for the original DHCP Inform request.


More Info: