cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
435
Views
0
Helpful
2
Replies
Jeremy10
Beginner

QOS Packet tracer

Hello, I sincerely apologize if I asked at the wrong place to post my questions. I am currently having difficulties with implementing QoS in packet tracer. We are tasked to implement Netflow for my routers and the direction I chose to use is from AR1 to AR2 ( According to my packet tracer file) to see the bandwidth consumption and have a capacity planning for my network diagram followed by implementing QoS. Our requirements for QoS are: "
1) Other traffic can be restricted to a maximum of 100kbps at all time
2) During congestion, minimum bandwidth can be guaranteed for the relevant applications
3) VoIP applied with QoS control policy delivered with minimum delay and improved jitter

Is it necessary to set a priority number for all of the requirements? Or is giving each class-map a certain amount of bandwidth enough? Do "Other traffic" refers to "UDP-OTHER" in ip cache flow? How do we know when to use cs3, cs2, af12, af 23 etc...? All I know is that a higher number will be dropped first ( eg; af23 will be dropped first compared to af22 and af 31 will be dropped first compared to af 22) I am really sorry but I am quite confused and I have no idea on how to start implementing QoS as this is my first time implementing it.. I hope that someone will be kind enough to at least give me a guideline
2 REPLIES 2
pmckenzie
Participant

If you go into packet tracer samples there is a QOS set up already for you to look at

Here is a snippet

 

class-map match-all critical

match protocol eigrp

class-map match-any interactive

match protocol telnet

match protocol ssh

class-map match-any web

match protocol http

!

policy-map markingpolicy

class critical

set precedence 7

class interactive

set precedence 5

class web

set precedence 3

 

interface Serial0/0/0

ip address 172.16.12.1 255.255.255.0

tx-ring-limit 1

service-policy output markingpolicy

hold-queue 1 out

There are worlds out there where the sky is burning, where the sea's asleep and the rivers dream, people made of smoke and cities made of song. Somewhere there's danger, somewhere there's injustice and somewhere else the tea is getting cold" Dr Who
Jeremy10
Beginner

Hi, thanks for replying. Sorry for the late reply. I have a better understanding of QOS configurations in general now than before so I have attempted my first QOS config. Heres my configuration:

 

class-map match-any VOIP_DATA

match protocol rtp

match ip dscp ef

class-map match-any VOIP_control

match protocol h323

match protocol skinny

match ip dscp cs3

class-map match-any application

match protocol tftp

match protocol pop3

match protocol smtp

match protocol telnet

match protocol dns

match ip dscp af21

class-map match-any WEB

match protocol http

match protocol https

class-map match-any NM

match protocol ntp

match protocol icmp

match protocol syslog

match protocol snmp

match protocol rip

match ip dscp cs2

!

policy-map SetMK

class VOIP_DATA

set ip dscp ef

class VOIP_control

set ip dscp cs3

class application

set ip dscp af21

class WEB

set ip dscp af11

class NM

set ip dscp cs2

!

policy-map SetBW

class VOIP_DATA

bandwidth 300

class VOIP_control

bandwidth 100

class NM

priority 100

class WEB

bandwidth 100

class application

bandwidth 150

!

!

!

!

!

interface Loopback0

ip address 192.168.64.12 255.255.255.255

!

interface FastEthernet0/0

ip flow egress

ip address 10.32.77.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.162.30.1 255.255.255.0

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.162.40.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

bandwidth 800

ip flow ingress

ip address 10.32.70.134 255.255.255.252

clock rate 2000000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

 

May I ask why is it that when I tried to type the command " service-policy output SetBW" in s0/0/0 it shows "

I/f Serial0/0/0 class application requested bandwidth 150 (kbps), available only 0 (kbps)"? I checked my int s0/0/0 interface and it says that it has an available bandwidth of 600kbps, so I am unsure why it shows an error? 

Content for Community-Ad