cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
479
Views
10
Helpful
4
Replies

Router 888

tafa
Beginner
Beginner

Hello I have got this Cisco 888 router and I try to create my network. The problem is there are 4xL2 ports and I am not sure how to configure the VLANS. I recently started to learn networking and I am making a home lab now. So when I connect to the ISPs modem and set  a VLAN to take an IP via DHSP is ok, I can ping 8.8.8.8. But then I don't know how to make my network. So I need access to the internet in a 1st place.

2 Accepted Solutions

Accepted Solutions

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

So from the router, you are able to ping 8.8.8.8 ok, but on the Lan side, you are not able to get internet ?

you need to post - show run  (here so we can suggest what changes required for the Lan to work)

here is basic guidelines : (you need ACL, NAT inside and outside for this work)

video : https://www.youtube.com/watch?v=FfPJ_dvM_is

https://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/260-cisco-router-nat-overload.html

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

here is a sample configuration for two Vlans:

ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool VLAN1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool VLAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport access vlan 2
!
interface FastEthernet3
switchport access vlan 2
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface vlan 2
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet 4
ip address dhcp
ip nat outside
!
ip nat inside source list 1 interface Fastethernet4 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp

 

View solution in original post

4 Replies 4

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

So from the router, you are able to ping 8.8.8.8 ok, but on the Lan side, you are not able to get internet ?

you need to post - show run  (here so we can suggest what changes required for the Lan to work)

here is basic guidelines : (you need ACL, NAT inside and outside for this work)

video : https://www.youtube.com/watch?v=FfPJ_dvM_is

https://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/260-cisco-router-nat-overload.html

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks but I still do a mistake.

 

Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Router#show run
Building configuration...

Current configuration : 2037 bytes
!
! Last configuration change at 18:53:51 UTC Sun Sep 4 2022
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!


!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool Vlan 10
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool Vlan 20
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
cts logging verbose
license udi pid C888-K9 sn FCZ222410TN
!
!
!
!
!
!
!
controller SHDSL 0
!
!
!
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
switchport access vlan 10
no ip address
!
interface FastEthernet2
switchport access vlan 20
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan20
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0 overload
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
!
!
end

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

I have not looked the config, is this resolved or still issue, since i saw as marked as resolved so. please advise. before i will go through the config.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

here is a sample configuration for two Vlans:

ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool VLAN1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool VLAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport access vlan 2
!
interface FastEthernet3
switchport access vlan 2
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface vlan 2
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet 4
ip address dhcp
ip nat outside
!
ip nat inside source list 1 interface Fastethernet4 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers