Showing results for 
Search instead for 
Did you mean: 

Router(boot)> --- Can't get out of this mode Cisco 2514 router

Will Brad

I'm a returning student with not a lot of real world hands on experience (wasted a lot of time with things like GNS3), especially super legacy models such as the 2514 router, which is my current problem child. I purchased a stack well over a decade ago and just pulled it out of my storage, so they do belong to me, BUT I am not a current enterprise paying partner with Cisco except as a student, so I don't think they'll help me especially since this is way way way out of support for them.  Out of my old legacy stack of switches and routers, I got everything up and running except this one pain in the rear router, which has frustrated me to this point.  I've spent 2 straight days not getting this series of problems fixed.  Yes, I've read a lot of threads on here, but I couldn't either understand fully or the info was unique to them.  I even consulted Cisco documents. So, I figured I'd just suck it up and ask for help. 


**please don't assume I know what you're talking about if you don't spell it out for me and this will also help other frustrated students reading this in the future**


First problem is it came up with obvious memory errors, so I unplugged it, cracked it open and reseated the RAM - FIXED THAT!


2nd problem is it came up with a secret password I couldn't guess, so I broke in with with Ctrl+break and issued #config-register 0x2142 from enable mode.  The real current problem now is that I think I bricked it while guessing how to set it back to factory defaults while frustrated and randomly throwing commands like write erase, copy run start, copy start run, erase flash, etc  I can't recall everything I typed, but I used help a lot and tried everything that looked remotely close to a working solution.


Now I'm stuck in Router(boot)>  ---  (I think this is called the boot helper mode for this series router)


I've tried:

Router(boot)#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(boot)(config)#config-register 0x2102  --- (and also 0x2101 in other attempts)

System configuration has been modified. Save? [yes/no]: n
Proceed with reload? [confirm]  ---just hit enter


Show version (or "sh ver" for anyone else reading along) confirms I successfully went to both 0x2102 and 0x2101, but am still stuck in "Router(boot)>" helper mode after not saving changes and reloading (as seen above).  I may be wrong, but I think that tells me I probably erased the startup IOS.  Am I wrong?


I think my current question is lol... I have several IOS images to put back on it, but don't know how to tftp sever it back in this mode even after all the searching I've done.  How do I install an IOS from the boot helper mode?


I have TFTPD64 installed.  Is there an easier free version I should use?  I think I have it setup correctly, but just don't know the exact commands to issue for reimaging and from what mode to do this in.

Can anyone please help?  Sorry it was so long, but I want this to be very thorough for other students to understand later.







9 Replies 9

VIP Advisor VIP Advisor
VIP Advisor

Hi @Will Brad ,


Maybe this discussion can give you some help:



Thank you very much for your time and patience with me on this.

A) Richard, the next commenter in this thread, steered me back to your link reply and you both got 4 other likes so far. Definitely on-point advice! Respect...

B) I was at this link a few times in the past couple days but didn't get all the way through it successfully.  Ultimately, I couldn't ping either of my TFTP server of default-gateway in step 7.  I'm not convinced I'm plugged into the correct router port physically. I'm only using my Console RJ45 port and I tried the AUX RJ45 port, but I also have two 60-pin Serial port and two 15-pin AUX ports. TheTftpd64 server I installed (freeware I've used successfully over the years, except the 32 bit version) offered me multiple suggestions:

     1) loopback addresses and 169.254.x.x addresses.  I disregarded both of those immediately. 

     2) It also suggested 2 other static VM host IP addresses not currently in use which were on another subnet 192.168.1.x, as I'm using default class C /24 addressing.  Also disregarded those suggestions. 

     3) I went with the most logical address it offered 192.168.0.x (I'm using "x" because this site said not to insert personal info, although I doubt this really applies to me as I'm in a temp lab environment AND I think you get my drift.  The internal offered address happens to be the same IP as my dhcp assigned laptop 192.168.0.x which houses my TFTP server)

     4) I switched to seemingly simpler Solarwinds free TFTP and got the same identical results - ping to both tftp and default gate failure

C)  Skipping steps 2 through 4 as I was already in what appears the correct mode and version.  I did a Show version (sh ver) and it confirmed I am on 0x2101

Router(boot)>sh ver

     **presumably useless info omitted**

cisco 2500 (68030) processor (revision L) with 14332K/2048K bytes of memory.
Processor board serial number 05615613 with hardware revision 00000000
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
2 Ethernet/IEEE 802.3 interfaces.
2 Serial network interfaces.
32K bytes of non-volatile configuration memory.

Configuration register is 0x2101

D) Performing the same steps 5 and 6, last night, I'm stuck again at the same point.  Unable to ping both tftp server and def gate. Certainly I feel I'm missing something very basic here :-/

     1) Router(boot)>
     Router(boot)#conf t
     Enter configuration commands, one per line. End with CNTL/Z.
     Router(boot)(config)#int e 0
     Router(boot)(config-if)#ip add 192.168.0.x
     Router(boot)(config)#ip def

     System configuration has been modified. Save? [yes/no]: n
     Proceed with reload? [confirm]

     2) Step 7 ping failure...

          a) Router(boot)#ping 192.168.0.x
          % IP protocol not running     <-- my deadend

          b) Router(boot)#ping
          % IP protocol not running     <-- my deadend

          c) Additional internal network info via Windows CMD - "command line" aka DOS


          Windows IP Configuration

          Wireless LAN adapter Wireless Network Connection 7: :
          Link-local IPv6 Address . . . . . : fe80::xxxx:xxxx:xxxx:xxxx%27
          IPv4 Address. . . . . . . . . . . : 192.168.0.x
          Subnet Mask . . . . . . . . . . . :
          Default Gateway . . . . . . . . . : 192.168.0.x

          d) C:\Users\User>ping 192.168.0.x (both laptop and tftp server address)

          Pinging with 32 bytes of data:
          Reply from 192.168.0.x: bytes=32 time<1ms TTL=128
          Reply from 192.168.0.x: bytes=32 time<1ms TTL=128
          Reply from 192.168.0.x: bytes=32 time<1ms TTL=128
          Reply from 192.168.0.x: bytes=32 time<1ms TTL=128

          Ping statistics for 192.168.0.x:
          Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
          Approximate round trip times in milli-seconds:
          Minimum = 0ms, Maximum = 0ms, Average = 0ms

     3) Router(boot)#copy tftp flash

     % Invalid input detected at '^' marker.

     Router(boot)#copy ?
     flh-log Copy FLH log file to server

     Router(boot)#copy flh ?
     tftp Copy FLH log to TFTP server

     Router(boot)#copy flh tftp ?


I hope all this effort makes sense and someone sees the smoking gun where I went astray with probably something very elementary ;-/


Richard Burts
Hall of Fame Guru Hall of Fame Guru
Hall of Fame Guru

If you did perform the command erase flash then that is the cause of your current problem which would be that you no longer have an IOS image in flash. And if you do have an IOS image appropriate for this router then you are indeed fortunate. The solution will be to copy the new image to the router. The link provided by Luis does show one potential solution for how to copy the new image to the router. There may be a different option which could work for you. tftpdnld is a command in rommon to copy an image file to the router. It has been a very long time since I used a 2514 and I can not say for sure that the 2514 does support that command. But if it does then it would be good for you. To use it you need to set some variables, such as an IP address for your router interface, the address of the tftp server, and the image file name. Here is a link to an article about tftpdnld which may be helpful.







Thanks.  This is helpful new info I haven't seen yet.  I'll give it a go. MUCH appreciated!


First, heading up to look at Luis info to even get into ROMMON> mode.  Question... is this the basically the same as Router(boot)> mode on a different IOS? I've been trying to get to ROMMON> mode, but maybe I'm already there?  I was thinking they were completely different modes :-/

I'll be back with either more questions or a confirmed in-place solution, hopefully the latter.  To be continued...