cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
796
Views
0
Helpful
11
Replies

Same VLANs on different interfaces (Router, L3 Switch)

janic
Beginner
Beginner

RLconnection.png

I have a couple of questions about this network.

 

This is a part of configuration finishing with the error that stopped me.

S1(config)#vlan 10
S1(config-vlan)#name vlan10
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name vlan20
S1(config-vlan)#exit

S1#show vlan brief

S1(config)#int fa0/11
S1(config-if)#switchport access vlan 10
S1(config)#int fa0/12
S1(config-if)#switchport access vlan 20

Switch(config)#hostname S2
S2(config)#vlan 20
S2(config-vlan)#name vlan20
S2(config)#interface fa0/11
S2(config-if)#switchport access vlan 20


Switch>en
Switch#config t
Switch(config)#hostname S3
S3(config)#vlan 10
S3(config-vlan)#name vlan10
S3(config-vlan)#exit
S3(config)#vlan 20
S3(config-vlan)#name vlan20
S3(config-vlan)#exit
S3(config)#int fa0/12
S3(config-if)#switchport access vlan 10
S3(config)#int fa0/11
S3(config-if)#switchport access vlan 20

Switch>en
Switch#config
Switch(config)#hostname S4
S4(config)#vlan 20
S4(config-vlan)#name vlan20
S4(config-vlan)#exit
S4(config)#int fa0/11
S4(config-if)#switchport access vlan 20

Switch(config)#hostname L3
L3(config)#vlan 20
L3(config-vlan)#name vlan20
L3(config-vlan)#exit
L3(config)#interface fa0/2
L3(config-if)#switchport access vlan 20
L3(config-if)#exit

L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#interface fa0/1
L3(config-if)#switchport mode trunk


Router>en
Router#config t
Router(config)#hostname R1
R1(config)#

R1(config-if)#interface fa0/1.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip add 192.168.0.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
R1(config)#interface fa0/1.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip add 192.168.1.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
R1(config)#interface fa0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip add 192.168.0.2 255.255.255.0
% 192.168.0.0 overlaps with FastEthernet0/1.10
R1(config-subif)#

 

I tried to make two subinterfaces on each interface of the router, one for vlan10, one for vlan 20.

1. If that is not possible, should I make subinterfaces on fa0/1 of L3, and make a new connection between router and L3 switch?

2. I configured as trunk ports: fa0/24 of S1, fa0/24 of L3, fa0/24 of S3. Is that right? What about fa0/1 of S3 and fa0/24 of S4?

3. The given IP range was 192.168.0.0/23, so I made vlan10 192.168.0.0/24 and vlan20 192.168.1.0/24, cause I needed classfull network for ripv1 routing. Was that right?

 

I attached picture and packet tracer file. If I forgot to explain or mention something, ask me. Any help would be great, but be sure to explain it to me like I'm an idiot cause I'm new to this. This was an exam problem.

11 Replies 11

MBeaumont
Beginner
Beginner

No shut the interface fa0/1 on R1 (without going in to the sub interface),

Let me know if it works

I've downloaded the packet tracer file, you got quite a few problems,

What I said above will give you a good start and do the same with Fa0/0 on R1,

Hint, I would also check you got all trunk ports configured with VLAN 10 and 20,

So what you're saying is I don't need subinterfaces or what? Sorry I didn't quite get it.
And about the other thing, you mean I don't have both vlans created on each switch that I configured with trunk ports?

You do need the sub interfaces on R1 but you still need to no shut the port

Hi

 

1. If that is not possible, should I make subinterfaces on fa0/1 of L3, and make a new connection between router and L3 switch?

 It is possible and you can use Layer3 interface. Both ways can work but I suggest you keep going with trunk.

2. I configured as trunk ports: fa0/24 of S1, fa0/24 of L3, fa0/24 of S3. Is that right? What about fa0/1 of S3 and fa0/24 of S4?

Connection between switch put in trunk.

3. The given IP range was 192.168.0.0/23, so I made vlan10 192.168.0.0/24 and vlan20 192.168.1.0/24, cause I needed classfull network for ripv1 routing. Was that right?

  Use rip version 2, why V1?

You need to fix this error:

"% 192.168.0.0 overlaps with FastEthernet0/1.10"

If you are using   192.168.0.1 255.255.255.0 in interface fa0/1.10 you can not use   192.168.0.2 255.255.255.0 interface fa0/0.10.

You need to use a different network

 

Hey, as this was exam problem, I try to do it as the problem asks me to do, so that's why I have to use ripv1.

If you use subinterface on the Router and trunk on the switches, even the Layer3 switch, you dont need RIP at all. The only place you will have layer3 interface will be on the Router.

 If you need to use RIP, the communication between Switch Layer3 and Router must be Layer3.

Take a look on the file I attached. Only router have Layer3 on this case.

Network as it is is working now, but I noticed you changed some IPs on end devices.
Shouldn't the PCs on the same VLAN has IP addresses of the same subnetwork? Also you used 255.255.255.128 as a subnet mask, but that doesn't count as class address (A:255.0.0.0, B:255.255.0.0, C:255.255.255.0 etc.). Am I wrong?

You are right and the reason  I did that is because I considered the range should be 192.168.0.0/23. 

Base on that, I broke this range in four smaller network:

192.168.0.0/25 - subnet 1 

192.168.0.128/25 - subnet 2

192.168.1.0/25 -  subnet 3

192.168.1.128/25 -  subnet 4

We can not have overlapping network on the topology.  In order to use only /24 network you need to have 4  /24 networks or use only vlan 10 and vlan 20 one in each side of the topology. As we have vlan 10 and vlan 20 on both sides of the topology, we need 4 networks. 

 

If I make the other network (10.1.1.0) between the router and L3 switch, can I make it work (having the vlan10:192.168.0.0 and vlan20:192.168.1.0 on both sides), by configuring the ripv1 routing on both L3 switch and R1 router. And if so, how should I configure ports on L3 switch?

No. Will not work.

 Look, if you add a network in the router interface like 192.168.0.0/24 there is no way the router look for this network elsewhere. If you try to ping from this mentioned network to some IP in this same range, the router will always try to find that IP inside never outside, dont matter if you have RIP or not.

 The router will only look outside if the IP you are trying to ping does not belong to its inside network.

 If you create a transit network 10.1.1.0 between Router and Layer3 switch  you will still be able to use 192.169.0.0/24 in one side. And 192.168.1.0/24 in the other side of the topology.

 What you can do is create vlan 10 on L3 and assign ip 192.168.0.0/24 and create vla  10 on router side and assign ip 192.168.1.0/24. Because vlan has local significance. VLAN ID does not matter but network does.

 You can try yourself

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: