cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3580
Views
0
Helpful
3
Replies
oliv Parcell
Beginner

SNMP statistics for GRE Tunnel interface statistics - not possible during the day

Hello !

We use Cacti to get interfaces statistics of a ASR1002 router (version 03.04.02.S.151-3.S2).

A new GRE tunnel has been created, but unfortunately we are not able to get basic interface average during the day.

What is surprising is the fact the graphs are built on the night only.

Tu_GRE_cacti_stats.JPG 

It seems as soon as we exceed some level of Bandwidth (~ 700-800k) the tool does not get the information

The OID I try to get are ifHCInOctets (.1.3.6.1.2.1.31.1.1.1.6) and ifHCOutOctets (.1.3.6.1.2.1.31.1.1.1.10) and some other interface statistics for both 64 and 32 bits.

I am wondering if the default BW of 100kbit/sec for the Tu0 is playing a role here =>

=========================================

Tunnel0 is up, line protocol is up

  Hardware is Tunnel

  Internet address is 172.18.70.73/30

  MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

     reliability 255/255, txload 255/255, rxload 255/255

  Encapsulation TUNNEL, loopback not set

  Keepalive set (5 sec), retries 3

  Tunnel source X.X.X.X, destination X.X.X.X

  Tunnel protocol/transport GRE/IP

  Key disabled, sequencing disabled

  Checksumming of packets disabled

  Tunnel TTL 255, Fast tunneling enabled

  Tunnel transport MTU 1476 bytes

  Tunnel transmit bandwidth 8000 (kbps)

  Tunnel receive bandwidth 8000 (kbps)

  Last input never, output 18:34:15, output hang never

  Last clearing of "show interface" counters never

  30 second input rate 5423000 bits/sec, 616 packets/sec

  30 second output rate 864000 bits/sec, 468 packets/sec

=========================================

Does someone has encountered this issue before.

Any suggestion would be much appreciated.

Best regards.

Oliv.


3 REPLIES 3
Alexey Leontiev
Beginner

Hello.

You have solved this problem?

Hello,

It was an issue on the Cacti side. After the Cacti team has recreated the graph, the issue has been fixed.

Best regards.

Oliv.

Hello,
I think it is a common issue for CACTI and some virtual interfaces. 
When Cacti generates DataSource as it described in DataQueries it uses |query_ifSpeed| for rrd_maximum field of the DataSource. Then somthing going wrong with interface speed determination.

 

In this case problem in the "SNMP - Interface Statistics" DataQuerу. And you can try to remove rule for the rrd_maximum field.