cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1183
Views
4
Helpful
24
Replies
Beginner

Software Distribution error 2960S - LMS4.2

Hello there

I am having a strange issue deploying universalk9-150-2.SE2 to our 2960S. All the switches are stand alones.

LMS gives an error when asking to upgrade the image but the fact is that the new software wents through - if I manually reload the switch everything is fine.

So my question is  - why is RME showing an error if the new image seems to have been deployed?

In attachement one telnet.log.

Thanks in advance for your help.

Everyone's tags (2)
24 REPLIES 24
Beginner

Software Distribution error 2960S - LMS4.2

Hello people

Any help on this one?

I have just upgraded 44 switches and out of 4 out of 44 went through with no issues.

The logs on LMS are not helping much and I can see on one of th switch that failed that the image was uploaded and extracted:

Directory of flash:/

    2  -rwx        1919  Apr 22 2013 10:27:39 +02:00  private-config.text

    3  -rwx         556   Mar 1 1993 01:02:11 +01:00  vlan.dat

  586  -rwx        6344  Apr 22 2013 10:27:39 +02:00  config.text

    5  -rwx        4120  Apr 22 2013 10:27:39 +02:00  multiple-fs

  606  drwx         512   May 2 2013 12:42:54 +02:00  c2960s-universalk9-mz.150-2.SE2

The LMS error I can se is this:

--------------------------------------------------------------------------------------------------

Processing Device : HX927353_SW16

Start Time : Thu May 02 12:33:23 CEST 2013

Device is locked for exclusive access.

The supported protocols for image transfer are: TFTP

Connecting to the device using SSH...

Connected successfully.

Going to perform delete operation based on the patterns in the List [.*\.bin, html, snmp, help, .*\.tar]

Files that will be excluded from deletion are: [vlan\.dat, config\.text, config\.txt, private-config\.text, private-config\.txt, multiple-fs, env_vars, system_env_vars, info\.ver, info]

Storage from which files are to be deleted is: flash1

Available Flash files: private-config.text,vlan.dat,config.text,multiple-fs,c2960s-universalk9-mz.150-2.SE2,

private-config.text -> will be excluded from deletion. File matched with the pattern: "private-config\.text"

vlan.dat -> will be excluded from deletion. File matched with the pattern: "vlan\.dat"

config.text -> will be excluded from deletion. File matched with the pattern: "config\.text"

multiple-fs -> will be excluded from deletion. File matched with the pattern: "multiple-fs"

c2960s-universalk9-mz.150-2.SE2 -> Doesn't match with the patterns in the delete list.

Obtained sufficient free space after deletion.Proceeding with distribution operation

Retrieving configuration file from the device...

Current device config is copied to /var/adm/CSCOpx/files/rme/jobs/swim/3005/HX927353_SW16_Config

Checking if HTTP server is enabled on the device...

Http Server is not enabled, will continue with Software Upgrade Operation.

Copying c2960s-universalk9-tar.150-2.SE2.tar from Software Repository to tftp-specific directory.

Copied successfully to /tftpboot/rep_sw_307934184362885541

Loading image file to flash device : rep_sw_307934184362885541 --> flash1:c2960s-universalk9-tar.150-2.SE2.tar using TFTP

Error loading image to Flash. See /var/adm/CSCOpx/files/rme/jobs/swim/3005/HX927353_SW16_telnet.log for the output from the device on which the image transfer failed.

Image Copy Operation Failed

Device is unlocked.

Device Upgrade Result : Failed

End Time:Thu May 02 12:39:26 CEST 2013

-----------------------------------------------------------------------------------------------------------

Any hints on could be causing this?

Best regards

Isaac

Cisco Employee

Software Distribution error 2960S - LMS4.2

It has the following error :

Loading image file to flash device : rep_sw_307934184362885541 --> flash1:c2960s-universalk9-tar.150-2.SE2.tar using TFTP

Error loading image to Flash. See /var/adm/CSCOpx/files/rme/jobs/swim/3005/HX927353_SW16_telnet.log for the output from the device on which the image transfer failed.

Image Copy Operation Failed


Shows the image from NMSROOT/tftpboot/ was not able to get copied to device. Please check manually if you can do so?

MOstly this file rep_sw_307934184362885541 should be in the NMSROOT/tftpboot directory, in case not, please create any normal text file in that directory and give it complete RW access to all users.

Than try the using copy .

Check and update.

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Beginner

Software Distribution error 2960S - LMS4.2

Hey Vinod

The file rep_sw_307934184362885541 is not in the tftpboot folder. I have 9 other files of the same type but this one is not there.

I have created a file called demo.txt and could successfully copy from the tftp server to the switch.

SW16#copy tftp://x.x.x.x/demo.txt demo.txt

Destination filename [demo.txt]?

Accessing tftp://x.x.x.x/demo.txt...

Loading demo.txt from x.x.x.x (via Vlan2559): !

[OK - 5 bytes]

5 bytes copied in 8.022 secs (1 bytes/sec)


Thanks for your help!

Best

Isaac


Cisco Employee

Software Distribution error 2960S - LMS4.2

PLease enable debug for SWIM and clear content of /var/adm/CSCOpx/log/swim_debug*.log. Run a new job on this device and share SWIM_debug.log and the telnet.log.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Beginner

Re: Software Distribution error 2960S - LMS4.2

Hello Vinod

I have deleted all the files in the log directory that werre relatated with SWIM (rm swim*) and enabled on

Admin > System > Debug Settings > Config and Image Management Debugging settings under software management  - hope this is the rigfht place to enable debug on SWIM?

Run the job again on the same switch and again failed:

Both files are attached

Thanks for bearing with me.

Isaac


Beginner

Software Distribution error 2960S - LMS4.2

Hello again

With the help of Emiliano have we tried to fix the issue changing the telnet and read time timeouts, but after having changed those values can not deploy new software.

I got an error message that reads:

SWIM0004: Could not get the device context.

Have already restarted the Daemon Manager with no success.

Have you had time to check the log files I attached on last week?

Really need some help here.

Best

Isaac

Highlighted

Software Distribution error 2960S - LMS4.2

Hello

•1.       Increase Read delay to 900 and telnet time out to 1000 via LMS link  Admin -> Collection Settings -> Inventory -> Edit the Inventory/Config Timeout and retry the job

•2.       If job failed again, increase the session time out in device to 40 by using the command ‘ip ssh time out ’

By

Emiliano

Beginner

Re: Software Distribution error 2960S - LMS4.2

Hello Emiliano

Thanks for your reply.

I did the changes suggested by you on point 1 and started the deployment job - failed.

Afterwards did the changes suggested on point 2 and started the deployment job again - failed.

PS: You asked me though to change the the time out for telnet to 1000 s. Is'nt that maybe to much?

Best

Isaac

Message was edited by: Isaac Alves

Re: Software Distribution error 2960S - LMS4.2

Hi,

Do you have verified that the options have been applied in step one? Because I have had the same problem and I solved Increase Read delay to 900 and telnet timeout to 1000. Because do inline edit first and then apply to me the first time I

has escaped to apply, please attach a screenshot of the settings.

The problem happens when you make an update to ios 12. * to 15. *

Let me know hello Emiliano

Beginner

Re: Software Distribution error 2960S - LMS4.2

Hello again

@Emiliano : You were right. The changes had not been aplied.

After having changed them I am not able to start the deployment cause RME can not check device context.

Have deleted the device and now I am runing a new discovery.

I will keep posted.

Best

Isaac

Beginner

Re: Software Distribution error 2960S - LMS4.2

Hello

As soon as I change the parameters you said I got this error under "View Verifications":

SWIM0004: Could not get the device context.

Did you got any issues when changing the timeout parameters?

Best

Isaac

Re: Software Distribution error 2960S - LMS4.2

Hi already tried to delete all the information on the switch that has problems ? and then discovery of new device.

Beginner

Re: Software Distribution error 2960S - LMS4.2

Hei Emiliano

Yes. Tried that twice. Unfortunately as soon as I change those parameters is not possible to deploy the new software - also with a fresh discovered device.

Any ideas?

Cheers

Isaac

Re: Software Distribution error 2960S - LMS4.2

You can post the error under verification view, and edit device attributes.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards