cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2408
Views
0
Helpful
4
Replies
fasih2012
Contributor

Unable to poll SNMP data from Nexus 7010

I have two Nexus 7010 in the data center. I'm unable to poll SNMP data from one of the NEXUS 7010s. The other Nexus 7010 is working fine.  I have compared the SNMP configurations, and they are identical. When I do "show snmp" on the non-working switch, I have SNMP packets in "Unknown Context name", not sure why. I have done show vdc and it matches the working switch output.

Here is output of show snmp from the non-working switch:

133 SNMP packets input
        0 Bad SNMP versions
        0 Unknown community name
        0 Illegal operation for community name supplied
        0 Encoding errors
        0 Number of requested variables
        0 Number of altered variables
        0 Get-request PDUs
        0 Get-next PDUs
        0 Set-request PDUs
        0 No such name PDU
        0 Bad value PDU
        0 Read Only PDU
        0 General errors
        0 Get Responses
        133 Unknown Context name
0 SNMP packets output
        0 Trap PDU
        0 Too big errors
        0 No such name errors
        0 Bad values errors
        0 General errors
        0 Get Requests
        0 Get Next Requests
        0 Set Requests
        0 Get Responses
        0 Silent drops


Community            Group / Access      context    acl_filter
---------            --------------      -------    ----------
xxxxxxxxxx          network-admin       v.e       
yyyyyy              network-operator    v.e       


______________________________________________________________
                  SNMP USERS
______________________________________________________________

User                          Auth  Priv(enforce) Groups                       
____                          ____  _____________ ______                       
josh                          md5   des(no)       network-admin                

admin                         md5   des(no)       network-admin                

carol                         md5   des(no)       network-admin                

fasih                         md5   des(no)       network-admin                

______________________________________________________________
NOTIFICATION TARGET USERS (configured  for sending V3 Inform)
______________________________________________________________

User                          Auth  Priv
____                          ____  ____


SNMP Tcp Authentication Flag : Enabled.

-------------------------------------------------------------------------------------------
Port Monitor : enabled
-------------------------------------------------------------------------------------------

Policy Name  : default                        
Admin status : Not Active
Oper status  : Not Active
Port type    : All Ports
-------------------------------------------------------------------------------------------
Counter          Threshold  Interval Rising Threshold event Falling Threshold  event In Use   
-------          ---------  -------- ---------------- ----- ------------------ ----- ------   
Link Loss        Delta      60       5                4     1                  4     Yes      
Sync Loss        Delta      60       5                4     1                  4     Yes      
Protocol Error   Delta      60       1                4     0                  4     Yes      
Signal Loss      Delta      60       5                4     1                  4     Yes      
Invalid Words    Delta      60       1                4     0                  4     Yes      
Invalid CRC's    Delta      60       5                4     1                  4     Yes      
RX Performance   Delta      60       2147483648       4     524288000          4     Yes      
TX Performance   Delta      60       2147483648       4     524288000          4     Yes      
-------------------------------------------------------------------------------------------

SNMP protocol : Enabled

4 REPLIES 4
ted.schwind
Beginner

Did you ever get this resolved? We have a pair of 7010s that were working just fine with snmpv3 and then one of them stopped authenticating. I have stripped the snmp configs and reapplied to no avail.

ted.schwind
Beginner

Found the cause. The snmp process crashed on the N7K.

What is the fix for it?  I was thinking to upgrade to the latest release. 

dknoezinger
Beginner

Hi,

This issue is pretty likely caused by a Bug existing in NX-OS 4.x and 5.x: CSCti07871

A workaround is to completely remove the SNMP community configuration and reapply only the necessary part.

Regards,

Daniel

Content for Community-Ad