cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
567
Views
0
Helpful
1
Replies

Upgrade LMS 3.2 and PI1.2

Scott O'Brien
Beginner
Beginner

Hi All,

I have a project to upgrade LMS3.2 to a new PI 1.2. my current plan is

1. build a new VM to install LMS 4.2

2. backup LMS 3.2 ( not SP1)

3. import 3.2 data to the new 4.2 machine

4.build a PI 1.2 and import 4.2 data into PI 1.2

5. run the devices side by side untill parity

As 3.2 is not SP1 can the data still be migrated into 4.2 or will I need to upgrade 3.2 to 3.2.1 ( SP1)?

Is there a script to backup/restore data from 3.2 to 4.2?

Migrating from 4.2 to PI 1.2 is there a script for this also?  

1 Reply 1

Vinod Arya
Cisco Employee
Cisco Employee

It is mandatory to upgrade to LMS 3.2 SP1 (aka LMS 3.2.1) if you intend to migrate data to LMS 4.2.

In LMS 3.x you can take backup via GUI (from CS > Server > Admin > backup) or else using NMSROOT/bin/backup.pl script.

On LMS 4.2 you can restore the same data using NMSROOT/bin/restorebackup.pl command.

For more details on Data Migration, please check the Install/upgrade guide section :

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/4.2/install/guide/dmg.html#wp1225292

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: