cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2261
Views
0
Helpful
5
Replies

Vlans can not reach DHCP server

gianlucanotaro
Level 1
Level 1

Topology:

 

I have 4 Different vlans(10Mitarbeiter,20Informatik,30Kader,40Support) Communication between them works fine. 

I have set up the DHCP server like this:

 

 

However when I try to use dhcp on any machine it does not work. It always goes to APIPA.

 

Switch config for all switches(except the access/trunk part. That part works fine)

 

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SEntwicklung
!
enable password class
!
!
!
ip ssh version 2
ip domain-name SwitchB3
!
username admin privilege 1 password 0 dnet2
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 30
!
interface FastEthernet0/4
 switchport access vlan 40
!
interface FastEthernet0/5
 shutdown
!
interface FastEthernet0/6
 shutdown
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface FastEthernet0/13
 shutdown
!
interface FastEthernet0/14
 shutdown
!
interface FastEthernet0/15
 shutdown
!
interface FastEthernet0/16
 shutdown
!
interface FastEthernet0/17
 shutdown
!
interface FastEthernet0/18
 shutdown
!
interface FastEthernet0/19
 shutdown
!
interface FastEthernet0/20
 shutdown
!
interface FastEthernet0/21
 shutdown
!
interface FastEthernet0/22
 shutdown
!
interface FastEthernet0/23
 shutdown
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 shutdown
!
interface GigabitEthernet0/2
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 0003.e455.2801
 ip address 192.168.1.1 255.255.255.128
 ip helper-address 192.168.3.193
!
interface Vlan20
 mac-address 0003.e455.2802
 ip address 192.168.1.129 255.255.255.192
 ip helper-address 192.168.3.193
!
interface Vlan30
 mac-address 0003.e455.2803
 ip address 192.168.3.1 255.255.255.128
 ip helper-address 192.168.3.193
!
interface Vlan40
 mac-address 0003.e455.2804
 ip address 192.168.3.129 255.255.255.192
 ip helper-address 192.168.3.193
!
!
!
!
line con 0
!
line vty 0
  cisco
 login local
 transport input ssh
line vty 1 4

 login
line vty 5 15
 login
!
!
!
!
end

any kind of help is greatly appreciated

 

 

5 Replies 5

luis_cordova
VIP Alumni
VIP Alumni

Hi @gianlucanotaro 

 

If it is an exercise in Packet Tracer, compress it (winzip) and attach it to check.

 

Regards

Hi @gianlucanotaro;

 

Please let me know it is a live environment or Practice purpose.

 

you can try 1 thing here connect the dhcp server to one of the switch and connect your laptop to the same switch where your dhcp is connected and check whether your dhcp is working or not.

 

if your dhcp is working fine on the switch then check on other switches configuration like allowing vlans on the trunk on both side, if particular vlans are allowed.

 

and also you can try by creating a dhcp pool on the switch and test the dhcp pool from the switch.

@luis_cordova @mohammedshahidali88 

 

its not a live environment.

 

 

PS: Added the zip 

On the DHCP server, trying using a trunk port with access to all the VLANs listed. On the PCs you will also need to reboot

Hi @gianlucanotaro 

 

I have reviewed your exercise and, apparently, you are not clear about some concepts.
For example:
-Assignment of ports to the corresponding vlan.
- Broadcast domains according to vlan.
-Static routing.

 

I suggest you review these concepts and / or consult your instructor about them.

 

Regards