cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
282
Views
15
Helpful
5
Replies

Why doesn't CDP Neigh list everything connected to your switch?

JWHolm81891
Beginner
Beginner

I've tried to find an answer to this on my own, but I'm not having much luck so I'm just going to ask it. I have Layer 2 switches in my network and there are times when running sh cdp niegh it doesn't listed everything that's connected. I have an IE switch that I ran the command on this morning and despite having devices plugged into Fa 1/3, 1/4 and Gi 1/1 the output lists nothing. Why is this? Are there just some devices cdp neigh won't list? 

1 Accepted Solution

Accepted Solutions

David Ruess
Rising star
Rising star

Hello,

 

Since CDP is CISCO proprietary you may not get all the results of a non CISCO device. In addition to what others said, the other standard is LLDP (Link Layer Discovery Protocol). On CISCO CDP is enabled by default and LLD is disabled by default I believe. You can enable LLDP globally or per interface with the commands:

Globally:

lldp run

Interface:

lldp transmit

lldp receive

 

You need both commands on interface for transmit/receive functions

See if "show lldp neighbors" shows any information after you enable it.

 

Hope that helps

 

-David

View solution in original post

5 Replies 5

ammahend
Collaborator
Collaborator

are devices on port Fa 1/3, 1/4 and Gi 1/1 Cisco devices ? if Yes, is CDP enabled on them ?

-hope this helps-

balaji.bandi
VIP Guru VIP Guru
VIP Guru
despite having devices plugged into Fa 1/3, 1/4 and Gi 1/1 the output lists nothing.

what device is this ? they capable of CDP ? Only switches and router have capabilities of CDP enable devices.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

David Ruess
Rising star
Rising star

Hello,

 

Since CDP is CISCO proprietary you may not get all the results of a non CISCO device. In addition to what others said, the other standard is LLDP (Link Layer Discovery Protocol). On CISCO CDP is enabled by default and LLD is disabled by default I believe. You can enable LLDP globally or per interface with the commands:

Globally:

lldp run

Interface:

lldp transmit

lldp receive

 

You need both commands on interface for transmit/receive functions

See if "show lldp neighbors" shows any information after you enable it.

 

Hope that helps

 

-David

Thank you! It's been a while since studying for my CCNA and I should've known that. lol Thanks for reminding me. You're absolutely right.