Showing results for 
Search instead for 
Did you mean: 
Mark Detchemendy

You don't have permission to access /cwhp/LiaisonServlet on this server.

Our CiscoWorks server rebooted and afterwards we received the following error message.

You don't have permsiion to access /cwhp/LiaisonServlet on this server.

I have recreated the SSL certificate.

I have stopped and restarted the Daemon service. No help.

I have attached a screenshot of the services running on the server.

Vinod Arya
Cisco Employee

Try without SSL in HTTP mode.

Try disabling it with CLI :

NMSROOT/bin/perl  NMSROOT/MDC/Apache/ -disable

Followed by a resetcasuser :


Do you see any error in NMSROOT/MDC/tomcat/logs/stdout.log or stderr.log? Is this a fresh install? or was working fine? Any new software service installed on server? try to disable the AV before daemon restart.


-Thanks Vinod **Rating Encourages contributors, and its really free. **


we are facing the same problem. Everything was working fine until we changed the page file size. We also encountered the same issue when the VM server got more RAM. We are running Cisco Prime LMS 4.2

Troubleshooting so far:

rebooted the server

restarted the crmdmgtd

all services are set to manual (only Cisco Prime Daemon is set to automatic)

Tried to run NMSROOT/MDC/Apache/ -disable but the CLI just hangs and it seems like the command was not executed properly.

Reset the casuser

The issue still persists.

Stdout and Stderr logs are attached.

I had the same issue, here's what TAC had me do, and calling the perl environment specifily for the scripts

Log into console as a local administrator and run this command


Set the password manually (think its option 2 from the menu)

Now perform this procedure:

1) Stop LMS application

  >  net stop crmdmgtd

2) remove server.* under NMSROOT\MDC\Apache\conf\ssl

3) Toggle SSL, you will be asked to fill in some fields, the only one

that is mandatory is the Hostname which should match what you use to log

into the server (http://:1741).

NMSROOT\bin\perl NMSROOT\MDC\Apache\bin\ -disable

NMSROOT\bin\perl NMSROOT\MDC\Apache\bin\ -enable

4) Run this step only if you are NOT using SSL mode (https://...).

NMSROOT\bin\perl NMSROOT\MDC\Apache\bin\ -disable

5) Start LMS application

  >  net start crmdmgtd

6) Ensure that the following files are created under





This worked for me with one slight correction, in my installation (windows) the script is located in

    NMSROOT\MDC\Apache and not NMSROOT\MDC\Apache\bin

Thank you @dcrown

This solved my problem.

The only change is the is located in:


- Andre


I have got it fixed with the steps that Vinod posted. I just overlooked the "perl" command.

Apply to the answers from Vinod and dcrown I have the problem to execute the command
NMSROOT\bin\perl NMSROOT\MDC\Apache\bin\ -disable
There is no file perl.exe under cscopx\bin

For info: the error appears after changing from http to https.

What is your LMS server version? Are you on windows or Unix(solaris)/Linux serevr?

if its Unix/Linux, it should not be .exe. See it from Solaris output :

bash-3.00# ls -l perl

-rwxr-xr-x   1 casuser  casusers   10908 Jul 13  2011 perl

bash-3.00# file perl

perl:           ELF 32-bit MSB executable SPARC Version 1, dynamically linked, not stripped


The is perl script which will excute with perl only;

NMSROOT/bin/perl  NMSROOT/MDC/Apache/ -disable -


-Thanks Vinod **Rating Encourages contributors, and its really free. **

It´s Windows Server 2008R2

Could you share NMSROOT/CSCOpx/bin>Dir output. Also the LMS version.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

It´s LMS 4.1

installed yesterday.

First problem solved '

Reason was the wrong folder from the old installation of LMS4.0. Now the path for LMS4.1 is c:\programm files (x86)\...

But now, another problem occures: I can´t connect to the server anymore, neither with http nor with https.

What is the error you see now? What is the output of pdshow, to check all processes are working?

If the old data is still there for LMS 4.0, there might be some residual registry entries which may be causing issues as well.

In c:\ you should have your install log, in last 15-20 lines it shows any error you get while installation. Can you check and see if LMS 4.1 was clean or encountered errors while installing?

If it never worked remove all of it and re-install. If so, make sure after remove and check there is no older entry.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

I´m goping crazy...

...after I got back from lunch I wanted to show a colleague the issue. Now I can connect to the server again http://:1741  and will redirect to https:///CSCOnm/servlet/login/login.jsp  But after insert the credentials I get the initial error message You don't have permission to access /cwhp/LiaisonServlet on this server

I´m beginning to think I´m too stupid...

Andy yes, I did an update from 4.0 to 4.1 with some problems, so I deinstalled all application which I dont need and re-installes with only one error shown in the install-log. But these was an install-error of java and I installed it later successfully.

I read something about a special cleaning tool for deinstall. Do you know this? Where can I get it?