cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1051
Views
10
Helpful
3
Replies
Added Solucoes
Beginner

AnyConnect VPN does not connect to the tunnel at some service providers

Good Morning,

I received complaints from remote users who connect to the AnyConnect VPN, where some service providers do not allow them to connect.
They have already performed a local test using the adsl link and do not connect to the VPN tunnel, but if you use another service provider on the same device, the VPN tunnel is established.
Is there any configuration or anything I can do to resolve this?

Below is part of the VPN configuration.

: Hardware: ASA5510, 1024 MB RAM, CPU Pentium 4 Celeron 1599 MHz
:
ASA Version 9.1(7)4
!

ip local pool VPNPool1 ...205.254 mask 255.255.255.0
!

asdm image disk0:/asdm-711-52.bin

route outside 0.0.0.0 0.0.0.0 200.186.???.?? 1

dynamic-access-policy-record DfltAccessPolicy
aaa-server LDAP protocol ldap

user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL

no snmp-server location
no snmp-server contact

crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint TPSSLVPN
enrollment self
fqdn vpn.corporation.com.br
subject-name CN=vpn.corporation.com.br,OU=SSLVPN,O=corporation,C=BR,St=Rio de Janeiro,L=Rio de Janeiro
keypair SSLKey
proxy-ldc-issuer
crl configure
crypto ca trustpoint TPcorporation
enrollment self
fqdn vpn.corporation.com.br
subject-name CN=vpn.corporation.com.br
keypair KEYcorporation
crl configure
crypto ca trustpool policy
crypto ca certificate chain TPSSLVPN
quit

crypto ca certificate chain TPcorporation
quit
crypto ikev2 remote-access trustpoint TPcorporation


webvpn
enable outside
anyconnect-essentials
anyconnect image disk0:/anyconnect-win-4.7.01076-webdeploy-k9.pkg 1
anyconnect image disk0:/anyconnect-macos-4.7.01076-webdeploy-k9.pkg 2
anyconnect enable
tunnel-group-list enable
cache
disable
group-policy DfltGrpPolicy attributes
dns-server value ...
vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client ssl-clientless
default-domain value corporation.com.br
group-policy GroupPolicy_SSLcorporation internal
group-policy GroupPolicy_SSLcorporation attributes
banner ...
wins-server value ...
dns-server value ...
vpn-filter value fw-gpac01
vpn-tunnel-protocol ssl-client
split-tunnel-policy tunnelspecified
split-tunnel-network-list value split-tunnel
default-domain value corporation.com.br
tunnel-group SSLcorporation type remote-access
tunnel-group SSLcorporation general-attributes
address-pool VPNPool1
authentication-server-group LDAP
default-group-policy GroupPolicy_SSLcorporation
tunnel-group SSLcorporation webvpn-attributes
group-alias SSLcorporation enable

class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
!
service-policy global_policy global

3 REPLIES 3
Rob Ingram
VIP Mentor

Hi,
This sounds more like a service provider issue than a problem with your configuration. Which protocol are you using SSL or IPSec? Some providers block IPSec, perhaps try using just SSL.

HTH

Thanks, I will do this test.

Sheraz.Salim
VIP Advocate

that seem to be a ISP blocker. in that case i noted in your configuration you have setup as following.

 

!

group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client ssl-clientless
group-policy GroupPolicy_SSLcorporation internal
group-policy GroupPolicy_SSLcorporation attributes
vpn-tunnel-protocol ssl-client
!

 

seem like you are hitting the "GroupPolicy_SSLcorporation internal" under this you have configured "vpn-tunnel-protocol ssl-client" if you using the system default group-policy in that case see above ASA define all the protocols.

 

in order to fix this you have to reconfigure this to ikev2. only if ssl is blocking by ISP.

here is link to configure the anyconnect to ikev2 configurations.

please do not forget to rate.
Content for Community-Ad