cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

564
Views
5
Helpful
3
Replies
Highlighted
Beginner

ASA - ASDM and FirePOWER Module compatibility

Hello,

I currently have the following versions in my Firewall:

 

ASA: 9.5(3)

ASDM: 7.7(1)

FirePOWER: 6.2.0-362

 

I need to upgrade the ASA version to 9.8(4) but I am having issues to understand if I need to upgrade anything else. If I check the ASA and Firepower compatibility, I can see that 6.2.X FirePOWER module is compatible with ASDM 7.7(1) and ASA 9.8.X but when I check ASA and ASDM compatibility, the Cisco document says that ASA 9.8(4) is compatible with ASDm 7.12(1). So, I am really confused if I can use ASA 9.8(4) with ASDM 7.7(1) according to this guide:

 

https://www.cisco.com/c/en/us/td/docs/security/asa/compatibility/asamatrx.html#id_59423

 

Can you please help me with this? Thank you very much.

Best Regards.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

You can use that newer ASA software while retaining the older ASDM. However you won't see (from the ASDM GUI) any of the new features it introduces until you also upgrade the ASDM.

There's generally no harm in upgrading ASDM since that only affects what the admin users see when configuring the firewall.

If you're even using the Firepower service module you should consider upgrading it for its own sake. Version 6.2.0 is getting quite old relatively speaking.

View solution in original post

3 REPLIES 3
Highlighted
Beginner

Adding more info, here you can check the screens about the parts which confused me. Thank you.

Highlighted
Hall of Fame Guru

You can use that newer ASA software while retaining the older ASDM. However you won't see (from the ASDM GUI) any of the new features it introduces until you also upgrade the ASDM.

There's generally no harm in upgrading ASDM since that only affects what the admin users see when configuring the firewall.

If you're even using the Firepower service module you should consider upgrading it for its own sake. Version 6.2.0 is getting quite old relatively speaking.

View solution in original post

Highlighted

Thank you very much. Yes, we will take opportunity to upgrade the Firepower service module too. Thanks :-)!

Content for Community-Ad