cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1540
Views
0
Helpful
6
Replies

ASA5505 9.2(3)4 Can't set security level via ASDM 7.3 OR 7.4

Mark^
Level 1
Level 1

I just upgraded from 8.3 to 9.4 and reset to factory on this 5505.  Now when I try to set the security level on any interface I received this error:

[ERROR] Interface
     No interface specified for interface_command

      Interface
[ERROR] security-level 100
    
security-level 100
  ^
ERROR: % Invalid input detected at '^' marker.

Of course I have no issues setting fro CLI.  I tried downgrading ASDM with no change in behavior.

 

Any ideas?

Mark
6 Replies 6

Vibhor Amrodia
Cisco Employee
Cisco Employee

Hi,

Can you enable the preview configuration option from the preferences on the ASDM and check what commands are being sent to the ASA device and post it on this post.

Also , explain the changes that you are making on the ASDM.

Thanks and Regards,

Vibhor Amrodia

I reset the asa to factory settings.  I've added an interface named "other" which was automatically assigned vlan12.  I can't set the security level on that interface.  On creation, it successfully creates the interface, but assigns it security level of 0.  If I try to assign it any other security level, I get the error posted above.

 

Enabling preview seems to explain why.  This is what is being sent to the asa when attempting to change the level to 90:

      Interface
        security-level 90


To add to this, I can't change the security level of either inside or outside interfaces either - I get the same exact message.

Mark

Adding an interface with preview enabled results in the below being sent to the asa:

      interface Ethernet0/3
        switchport access vlan 22
      Interface vlan22
        no shutdown
        nameif test
      Interface
        security-level 100

 

Mark

Hi,

I am sorry. I am able to understand that somehow the "interface" command is being sent which is error out.

I would request you to post some Screenshot of the changes you are trying to make and the initial config that u are starting with so that i can try to recreate this if possible.

Thanks and Regards,

Vibhor Amrodia

To recreate:

Update ASA 8.3 to 9.2(3)4

Install ASDM 7.4

Reset to factory defaults via ASDM

Using ASDM: add an interface and set any security-level

This is when you should see the error.

Mark

Were you able to reproduce?

Mark
Review Cisco Networking products for a $25 gift card