cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
335819
Views
2445
Helpful
141
Replies

ASDM "this app can't run on your PC" - Windows 10

patrick.hurley
Participant
Participant

I am getting this error when trying to launch ASDM.   New install of Windows 10 Professional.  I have been running this successfully on other Windows 10 PCs.  Has anyone seen this and know the fix?

141 Replies 141

Hi Ravee, I also shortened the path. I needed to install the latest Java on my laptop and then I was able to launch ASDM. Before I could install Java I needed to add www.java.com to the Firepower Whitelist on the Firepower Management Console.

Regards,
Rich

This worked for me as well. Thanks Scott!

 

Hello Scott!

 

Please tell me detail about that!

I can't not change wscript.exe to C:\Windows\System32\wscript.exe

because there same file exist!

Currently I face this issue I can not run asdm on window 10.

I attched photo

1st photo is file location

2nd photo is same file in  C:\Windows\System32\

 

Please tell me how do I solve this issue1st ASDM filelocation.jpg2nd in  CWindowsSystem32 .jpg

Yes, the file will exist in both locations.
 
However, your problem is that you changed the wrong field. Change "Target:" not "Start in:" and it will work.

Thank You!
Todd!
I got it!
I waste 3 hours for this issue.
With Respect!

Hi Todd,

I saw your post about this same issue I have with ASDM Launcher. I know the post is a bit old but I was wondered if you could help with my issue. The setting you mentioned to change is exactly the same on my windows 10 PC. However, ASDM launcher hangs for a while and eventually timeout. Do you have any idea what could be the issue? I attached a picture of my setting. Thanks.

Legend, thanks Scott. Worked perfectly for me as well.
I did open the shortcut and wonder what that crazy path was in the beginning too :)

Great catch Scott. Helped me also.

Work for me thanks.

This fix worked perfectly for me!

Hi,

 

What version of Java should we use? I have used java 8 u211 and it does not seam to work. The fix for the target did work

 

Kind Regards

I just upgraded to Java Version 8 Update 211 (build 1.8.0_211-b12) and ASDM is working fine.

I have also had past issues with Java and ASDM. However, all my problems went away with a clean install of Windows. I know that's a big ask just to get ASDM working, but it's Windows. Expect the unexpected.

For the moment, you might try uninstalling both Java and ASDM, rebooting and reinstalling both again.

Best of luck!

The issue seemed to be the security settings on java rather the version itself. Mine worked with version 8 Update 171 and the latest ASDM 7.12. The trick with the shortcut did the job as well for the issue "Application not compatible". 

Thanks

Nailed it!

Very Helpful! Thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: