cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

474
Views
0
Helpful
10
Replies
galashov_is
Beginner

C9300L-24T-4X MACSec

Hello! Im trying to configure macsec conections beetwen two C9300L-24T-4X , but when i try to use "sap pmk" command there is a message "% Unrecognized command" appears. How can i enable macsec functions?

10 REPLIES 10
balaji.bandi
VIP Master

what kind of License you have ?

 

show version can give you information.

 

You can look the requirement and Limitation :

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-12/configuration_guide/sec/b_1612_sec_9300_cg/macsec_encryption.html

 

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Technology Package License Information:

------------------------------------------------------------------------------
Technology-package                                                       Technology-package
Current                                      Type                                   Next reboot
------------------------------------------------------------------------------
network-advantage           Smart License                       network-advantage
dna-advantage           Subscription Smart License             dna-advantage

 

AIR License Level: AIR DNA Advantage


Smart Licensing Status: Registration Not Applicable/Not Applicable

what is the version of code ? can you post the config or post complete log when you configuring where you getitng the error to know for better understading ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Building configuration...

Current configuration : 10023 bytes
!
! Last configuration change at 15:52:59 UTC Thu Sep 16 2021 by admin
!
version 17.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
service sequence-numbers
service unsupported-transceiver
platform punt-keepalive disable-kernel-core
!
hostname Big_cisco_office
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
logging console emergencies
enable secret 9 $14$uFuN$caGxXnHe6RqcSU$y1h9m1h0ge920rjt49WMTs5yaunyz8MgzjIJLtQVxJw
!
aaa new-model
!
!
aaa session-id common
clock timezone UTC 3 0
switch 1 provision c9300l-24t-4x
!
login on-success log
!
!
no device-tracking logging theft
!
crypto pki trustpoint TP-self-signed-312483788
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-312483788
 revocation-check none
 rsakeypair TP-self-signed-312483788
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain TP-self-signed-312483788
 certificate self-signed 01
  3082032E 30820216 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33313234 38333738 38301E17 0D323130 39313630 37303832
  315A170D 33313039 31363037 30383231 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3331 32343833
  37383830 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 82010A02
  82010100 A26D9309 A9F62669 37D2ADC7 AF68F728 4340FB08 2518470D 7904C268
  D7F07E62 55A1D15D D0B725AE FFE91AAD BD312855 2A7F4334 56B7671C 31DD622B
  47B3B275 16F78A7E 46F0FD8E 84E20E6D 0B20A1FC E8331E0C C612234A 0C33CCE4
  4FA51F6A 973B64F9 AF869DE1 75252FB0 BFD813F3 7613E720 422284C1 CB4AC78D
  8F8F39E8 FCE07EFA 78671596 AE1201F2 6BCDA45A 2327E26B 65C1BFDA D68421FD
  51801DB3 544FB135 44AF5D85 AA36B9D1 9AF187CD 81743070 D9B32AD2 3EBCC8F7
  11008002 2046DF22 717D177C 52AA18CD 806B79AF 0B6D1B13 1C6A45A3 E352FC7A
  18E77288 60420024 371E08B9 5F22FC15 859ADD6A 69CE1274 5491F72A AD2CE60B
  86801FA5 02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F
  0603551D 23041830 16801440 298C4D6E B0E35E7F 740AD72D 054D7528 227E5530
  1D060355 1D0E0416 04144029 8C4D6EB0 E35E7F74 0AD72D05 4D752822 7E55300D
  06092A86 4886F70D 01010505 00038201 01000623 9851991F FC2178D1 21677CD8
  48377A11 3BF92EE9 F35582A9 955BC797 E79ED020 764B402E 342566FC FA31F38C
  148831CC B5E63B90 858758AC 77F89980 0B2FFFB7 94E7D242 DD4F59BA 18792E06
  B0893CCF 4F58B768 E8B80E7B 509B4DD0 680D198B 22E72674 5E94B1BF 2F6C2513
  9E5D906A FEA12541 53D45F1C 536CB0CD 06A3B852 51089320 440E9670 5089918A
  4B04A8DC 8022822F 71AB3EBE B4C6E59B 366097AB 61186612 D110A103 189D0A27
  79FE2EE9 61F0EA50 C2A585B2 5E2FA4D1 0D7D9D9E AD87151B E5276D35 34849DF3
  FD564433 9E78A004 6FDC0F32 8968D4D5 D1DFA0EB 743FE698 6092245A C32CAD40
  C80A5E58 E01EAAF3 198CFD3B A8C80EC8 2CFF
        quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0
  D697DF7F 28
        quit
!
!
license boot level network-advantage addon dna-advantage
!
!
diagnostic bootup level minimal
!
spanning-tree mode pvst
spanning-tree extend system-id
memory free low-watermark processor 133817
!
no errdisable detect cause gbic-invalid
no errdisable detect cause sfp-config-mismatch
username admin privilege 15 password 7 123909140001150A22212F386165704346
username dscuser privilege 15 password 7 06260B324F6E1C0A0005405B5E546B
!
redundancy
 mode sso
!
!
!
transceiver type all
 monitoring
hw-switch switch 1 logging onboard message
!
!
class-map match-any system-cpp-police-ewlc-control
  description EWLC Control
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data packets, LOGGING, Transit Traffic
class-map match-any system-cpp-default
  description EWLC Data, Inter FED Traffic
class-map match-any system-cpp-police-sys-data
  description Openflow, Exception, EGR Exception, NFL Sampled Data, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
  description MCAST END STATION
class-map match-any system-cpp-police-high-rate-app
  description High Rate Applications
class-map match-any system-cpp-police-multicast
  description MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual OOB
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control and Low Latency
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-dhcp-snooping
  description DHCP snooping
class-map match-any system-cpp-police-ios-routing
  description L2 control, Topology control, Routing control, Low Latency
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold Pkt
class-map match-any system-cpp-police-ios-feature
  description ICMPGEN,BROADCAST,ICMP,L2LVXCntrl,ProtoSnoop,PuntWebauth,MCASTData,Transit,DOT1XAuth,Swfwd,LOGGING,L2LVXData,ForusTraffic,ForusARP,McastEndStn,Openflow,Exception,EGRExcption,NflSampled,RpfFailed
!
policy-map system-cpp-policy
policy-map port_child_policy
 class non-client-nrt-class
  bandwidth remaining ratio 10
!
!
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface AppGigabitEthernet1/0/1
!
interface Vlan1
 ip address 10.10.9.150 255.255.252.0
!
ip default-gateway 10.10.11.250
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
control-plane
 service-policy input system-cpp-policy
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line vty 0 4
 logging synchronous
 transport input ssh
line vty 5 31
 transport input ssh
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
wsma agent exec
 profile httplistener
 profile httpslistener
!
wsma agent config
 profile httplistener
 profile httpslistener
!
wsma agent filesys
 profile httplistener
 profile httpslistener
!
wsma agent notify
 profile httplistener
 profile httpslistener
!
!
wsma profile listener httplistener
 transport http
!
wsma profile listener httpslistener
 transport https
!
end

looks like my cisco doesnt know macsec commands

 

try below

 

config t

!

inter ten1/1/1

cts man

sap ?

 

see if that work ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

I have already try it

 

(config-if)#cts manual
(config-if-cts-manual)#sap ?
% Unrecognized command

 

Is thats true - i need to activate smart account and install there my license to use crypto functions on 9300 ?

Smart Licensing Status: Registration Not Applicable/Not Applicable

i believe its register Network Advantage should work as per i know.

 

after cts man, exit and config on interface confif level

 

inter ten1/1/1

cts man

exit

(it will take some time to get activate) you will see mesage then issue below command

sap ?

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

No changes

 

(config-if)#cts man
(config-if-cts-manual)#exit
(config-if)#sap ?
% Unrecognized command

 


(config)#mka ?
% Unrecognized command
(config)#do show macsec ?
% Unrecognized command

 

 

 

 

galashov_is
Beginner

Any ideas? My licence is support macsec?

as per the output , yes it does.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Create
Recognize Your Peers
Polls
Which of these topics should we host an event in the Community?

Top Choice: ISE Demo (100%)

Content for Community-Ad