cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

370
Views
0
Helpful
7
Replies
haider.rizwan
Beginner

Cisco 5505 unable to communicate multiple VLANs

Hi 

I have Cisco ASA 5505 and configured 2 VLANs connecting to Cisco 2960 on access ports. both VLANs are unable to communicate.

where is the issue?

HAWK-ASA# show running-config
: Saved
:
ASA Version 8.2(5)
!
hostname HAWK-ASA
domain-name hsmea.com
enable password A4KROCQZQWlF.ct5 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
description WAN OUTSIDE
switchport access vlan 2
!
interface Ethernet0/1
description LAN INSIDE
!
interface Ethernet0/2
description Servers-Vlan
switchport access vlan 10
!
interface Ethernet0/3
description Voice Gateway 2811
switchport access vlan 10
shutdown
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.254 255.255.255.0
!
interface Vlan2
description OUTSIDE INTERFACE PPPOE
nameif outside
security-level 0
pppoe client vpdn group hawksol
ip address pppoe setroute
!
interface Vlan10
no forward interface Vlan1
nameif DMZ
security-level 100
ip address 10.172.192.254 255.255.255.0
!
ftp mode passive
clock timezone GST 4
dns server-group DefaultDNS
domain-name hsmea.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network HAWK_BURDUBAI_LAN
network-object 192.168.172.0 255.255.255.0
object-group network HAWK_HQ_LAN
network-object 192.168.1.0 255.255.255.0
access-list HAWKSOL_VPN_TRAFFIC extended permit ip 192.168.172.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list NO-NAT-TRAFFIC extended permit ip 192.168.172.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit icmp any any
access-list LANtoDMZ extended permit ip 192.168.1.0 255.255.255.0 10.172.192.0 255.255.255.0
access-list DMZtoLAN extended permit ip 10.172.192.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu DMZ 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list LANtoDMZ
nat (inside) 1 0.0.0.0 0.0.0.0
nat (DMZ) 0 access-list DMZtoLAN
static (inside,outside) tcp interface 3389 192.168.1.110 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set MYSET esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map OUTSIDE_MAP 1 match address HAWKSOL_VPN_TRAFFIC
crypto map OUTSIDE_MAP 1 set pfs
crypto map OUTSIDE_MAP 1 set peer 86.96.28.55
crypto map OUTSIDE_MAP 1 set transform-set MYSET
crypto map OUTSIDE_MAP interface outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
vpdn group hawksol request dialout pppoe
vpdn group hawksol localname nh1304
vpdn group hawksol ppp authentication pap
vpdn username nh1304 password *****
dhcpd dns 8.8.8.8
dhcpd auto_config outside
dhcpd option 150 ip 10.172.192.1
!
dhcpd address 192.168.1.50-192.168.1.80 inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 128.138.141.172 source outside
webvpn
username admin password FSSr.BWCYVdYyR3l encrypted privilege 15
tunnel-group HAWKSOL-BURDUBAI-HQ-VPN type ipsec-l2l
tunnel-group HAWKSOL-BURDUBAI-HQ-VPN ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:65b036723a684ccb0d439bcc28133a01
: end
HAWK-ASA#

1 ACCEPTED SOLUTION

Accepted Solutions

The ASA5505 with the Base license has restrictions on the use of the third vlan, part of which is seen in this config command

interface Vlan10
no forward interface Vlan1

I believe this is why the Inside and the DMZ are not able to communicate. Using the Plus license removes the restriction on the third vlan but I am assuming that this ASA probably has the Base license.

HTH

Rick

HTH

Rick

View solution in original post

7 REPLIES 7
gaowen
Beginner

Are the switch ports configured as access-ports? what is the show int ip brief on the firewall? I take it that the E0/0 and E0/2 connect to different switches?

Gareth

The ASA5505 with the Base license has restrictions on the use of the third vlan, part of which is seen in this config command

interface Vlan10
no forward interface Vlan1

I believe this is why the Inside and the DMZ are not able to communicate. Using the Plus license removes the restriction on the third vlan but I am assuming that this ASA probably has the Base license.

HTH

Rick

HTH

Rick

View solution in original post

Hi, ASA is connected to same switch but difference VLANs. I got it that third VLAN cannot communicate with other inside VLAN but third VLANs is also not going to internet.

what can be the possible issue.

Also, i wants to setup UDP port range forwarding for Cisco Jabber MRA, can you please advise 36,000 to 59,999 UDP port configuration?

current version of ASA is 8.2(5)

thank you a lot .

I believe that the reason why the third vlan does not get to the Internet is that there is no NAT configured for it. The only NAT that I see for DMZ is the nat exemption that is configured (and it puzzles me why that nat exemption is configured since the Inside vlan and the DMZ vlan would not talk to each other).

I am not clear what you want to do about port forwarding. Can you clarify this?

HTH

Rick 

HTH

Rick

Hi Richard,

I wants to configure udp port forwarding range 36,000 to 59,000 in Cisco asa 5505 9.2(4) to allow outside access of Cisco jabber for my internal resources.

I have already done static NAT in router but it's not possible to put list of commands in router so i decided to use ASA to use range command instead of manually adding.

Cisco router 2800 / 2900 doesn't support UDP port range command for port forwarding.

please advise how i can setup this port range in ASA.

thank you a lot. 

I believe this question was asked and answered in this discussion

https://supportforums.cisco.com/discussion/11508181/how-configure-nat-port-range-asa-5510

HTH

Rick

HTH

Rick

Hi Richard,

i followed the link but i have 2 questions.

1. it's translating range of ports however, i just wanted to port forward

2. second host which 10.2.2.2 i put WAN ip which ASA didn't accept.

please help to fix the issue.

"I wants to port forward UDP range (36,000 to 59,999)."

internal IP: 192.168.1.207

WAN IP: PPPoE ip address

thank you a lot. 

Content for Community-Ad