cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

441
Views
0
Helpful
6
Replies
rc00000011
Beginner

Cisco ASA 5505 (7.2) configuration mode PPOE don't work

Hello,

I have configured cisco ASA 5505 (7.2) in PPOE mode .  Unfortunately , this configuration not work . You will find bellow my configuration . 

Please help me to correct if there is any mistake .

Thank you!

 

++++++++

: Saved
:
ASA Version 7.2(4) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group INFO
 ip address 41.112.184.159 255.255.255.0 pppoe 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
 switchport access vlan 3
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit ip any any 
access-list inside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.1.0 255.255.255.0 dns
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route inside 0.0.0.0 0.0.0.0 192.168.1.60 tunneled
route outside 0.0.0.0 255.255.255.0 41.227.194.159 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp dmz
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group INFO request dialout pppoe
vpdn group INFO localname INFO07512@informatique.com
vpdn group INFO ppp authentication pap
vpdn username INFO07512@informatique.com password ********* store-local
dhcpd auto_config outside
!
dhcpd address 192.168.1.60-192.168.1.150 inside
dhcpd dns 41.122.103.55 8.8.8.8 interface inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect dns 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:c033b075f81937936c37463605ec9c63
: end

6 REPLIES 6
Vibhor Amrodia
Cisco Employee

Hi,

Provide the PPPOE debugs from the device while connecting to the modem,

debug pppoe event

debug pppoe error

debug pppoe packet

Thanks and Regards,

Vibhor Amrodia

Hi;

In the debug logs I got just those error messages:

PPPOE: PPP link down: Peer Terminated
PPOE: PPP link down

 

I will be appreciated for your help

Hi,

These messages only point out that the PPPOE link is down.

Are you able to connect a PC and then use this PPPOE connection ?

Did you try to enable the debugs on the ASA device and then reload he Modem so that it tries to re-initiate the tunnel ? Also , capture on the ASA device interface might be needed.

Thanks and Regards,

Vibhor Amrodia

 

Hi,

The only message that I get it is the "pppoe link down". Yes , I connect the pc to the ppoe connection and it work fine. I restart the modem and the cisco ASA5505 without any result. 

I do also an upgrade to the version of ios form 7.2 to 8.2 . Also in the configuration of the pppoe , I assigned an ip address to outside interface then i change it to be assigned automatically by the pppoe.

You will find in the attachment a screenshot that show the status of the interfaces , the debug logs .

 

Thank you for your help!

Best regards!

Hi Vibho ;

Please could you please help me to find a solution for this issue.

Thank you!

 

 

 

Hey,

Were you able to figure this out?

Content for Community-Ad