cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

670
Views
25
Helpful
5
Replies
Highlighted
Beginner

Cisco ASA5510 Network Speed is half

Hello,

 

Can anyone assist me with see why I only get half the Network Speed on my ASA. I have 1GIG Internet and I can only get 500 Mbps or less when using the ASA5510. Is this a license issue or something? I changed the speed to AUTO/AUTO or FULL/FULL that didn't work. The port should be able to handle 1GIG bc its giving me speeds more than 100 Mbps at the port. 

 

CONFIG:

HT-HOMEASA# sho run
: Saved
:
: Serial Number:
: Hardware: ASA5510, 1024 MB RAM, CPU Pentium 4 Celeron 1600 MHz
:
ASA Version 9.1(7)32
!
hostname HT-HOMEASA
enable password z2MeQrVsjStha93V encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
nameif OUTSIDE
security-level 0
ip address dhcp setroute
!
interface Ethernet0/1
nameif INSIDE
security-level 100
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
!

boot system disk0:/asa917-32-k8.bin
ftp mode passive
clock timezone CST -5
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list OUTSIDE_access_in extended permit icmp any4 10.10.10.0 255.255.255.0 echo-reply
access-list OUTSIDE_access_in extended permit tcp any 10.10.10.0 255.255.255.0 eq https
access-list OUTSIDE_access_in extended deny object-group TCPUDP any 10.10.10.0 255.255.255.0 eq www
pager lines 24
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu INSIDE 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-openjre-7131-101.bin
asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
nat (INSIDE,OUTSIDE) dynamic interface
access-group OUTSIDE_access_in in interface OUTSIDE
route OUTSIDE 0.0.0.0 0.0.0.0 X.X.X.X 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.10.10.0 255.255.255.0 INSIDE
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint ASDM_TrustPoint0
enrollment terminal
subject-name CN=HT-HOMEASA
crl configure
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh 10.10.10.1 255.255.255.255 INSIDE
ssh timeout 10
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd address 10.10.10.11-10.10.10.254 INSIDE
dhcpd dns 8.8.8.8 8.8.4.4 interface INSIDE
dhcpd enable INSIDE
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection scanning-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 64.225.34.103 source OUTSIDE
username truongasa password .HQT.YZuDBCK3.On encrypted
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:e2051d803daef460a25d441f8f66ba7b
: end

 

Outside INTERFACE:

HT-HOMEASA# sho int Ethernet0/0
Interface Ethernet0/0 "OUTSIDE", is up, line protocol is up
Hardware is i82546GB rev03, BW 1000 Mbps, DLY 10 usec
Auto-Duplex(Full-duplex), Auto-Speed(1000 Mbps)
Input flow control is unsupported, output flow control is off
MAC address f0f7.55f3.31f0, MTU 1500
IP address 192.168.182.124, subnet mask 255.255.255.0
3 packets input, 886 bytes, 0 no buffer
Received 1 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 pause input, 0 resume input
0 L2 decode drops
3 packets output, 1252 bytes, 0 underruns
0 pause output, 0 resume output
0 output errors, 0 collisions, 1 interface resets
0 late collisions, 0 deferred
0 input reset drops, 0 output reset drops, 0 tx hangs
input queue (blocks free curr/low): hardware (255/254)
output queue (blocks free curr/low): hardware (255/254)
Traffic Statistics for "OUTSIDE":
3 packets input, 832 bytes
3 packets output, 1180 bytes
1 packets dropped
1 minute input rate 0 pkts/sec, 0 bytes/sec
1 minute output rate 0 pkts/sec, 0 bytes/sec
1 minute drop rate, 0 pkts/sec
5 minute input rate 0 pkts/sec, 0 bytes/sec
5 minute output rate 0 pkts/sec, 0 bytes/sec
5 minute drop rate, 0 pkts/sec
HT-HOMEASA#
HT-HOMEASA# sho run int Ethernet0/0
!
interface Ethernet0/0
nameif OUTSIDE
security-level 0
ip address dhcp setroute

 

Inside INTERFACE:

HT-HOMEASA# sho int Ethernet0/1
Interface Ethernet0/1 "INSIDE", is up, line protocol is up
Hardware is i82546GB rev03, BW 1000 Mbps, DLY 10 usec
Auto-Duplex(Full-duplex), Auto-Speed(1000 Mbps)
Input flow control is unsupported, output flow control is off
MAC address f0f7.55f3.31f1, MTU 1500
IP address 10.10.10.1, subnet mask 255.255.255.0
197679 packets input, 101499316 bytes, 0 no buffer
Received 190 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 pause input, 0 resume input
0 L2 decode drops
557063 packets output, 715318523 bytes, 2615 underruns
0 pause output, 0 resume output
0 output errors, 0 collisions, 2 interface resets
0 late collisions, 0 deferred
0 input reset drops, 0 output reset drops, 0 tx hangs
input queue (blocks free curr/low): hardware (255/233)
output queue (blocks free curr/low): hardware (255/0)
Traffic Statistics for "INSIDE":
197679 packets input, 97316941 bytes
559678 packets output, 708693351 bytes
180 packets dropped
1 minute input rate 0 pkts/sec, 18 bytes/sec
1 minute output rate 0 pkts/sec, 5 bytes/sec
1 minute drop rate, 0 pkts/sec
5 minute input rate 78 pkts/sec, 3993 bytes/sec
5 minute output rate 303 pkts/sec, 426171 bytes/sec
5 minute drop rate, 0 pkts/sec
HT-HOMEASA#
HT-HOMEASA# sho run int Ethernet0/1
!
interface Ethernet0/1
nameif INSIDE
security-level 100
ip address 10.10.10.1 255.255.255.0

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
VIP Mentor

Personally, I do not believe that model supports a maximum of 300MB, the thread mentioned only to use gigabit interface (not mentioned you get 1Gig throughput).

 

The 5510 only have functional 1Gbs ports if you enable the security plus license

 

correct me unless i am reading wrong...

BB
*** Rate All Helpful Responses ***

View solution in original post

Highlighted

That is correct, with the security plus license you can configure those two interfaces in Gig, however, that is the bandwidth not the throughput. This means that even if both inside and outside interfaces are in Gig, as in your case, the actual speed of processing and passing the traffic between the ingress and the egress interfaces is always subject to the device throughput. The device throughput depends on many factors, mainly it depends on the security features you enable, more you enable, less throughput you get. A huge impact on the throughput would be deep packet inspection and SSL decryption. Generally speaking the ASA devices have been always known with this caveat, however, it is a different story with Firepower appliances.

View solution in original post

5 REPLIES 5
Highlighted
VIP Mentor

Look at the spec of 5510 

Firewall Throughput

Up to 300 Mbps

 

 

https://www.cisco.com/c/en/us/products/security/asa-5500-series-next-generation-firewalls/data_sheet_c78-345385.html

BB
*** Rate All Helpful Responses ***
Highlighted

Thanks for the reply. WOW I did not realize this. According to this article https://community.cisco.com/t5/network-security/asa-5510-is-it-gigabit-capable/m-p/1584660. If you have the Security Plus License Eth0/0 and Eth0/1 should be gig though? Which I have. Output is at the bottom.

 

HT-HOMEASA# show activation-key
Serial Number: XXXXXXXXXXXX
Running Permanent Activation Key: XXXXXXXXXXXXXXXXXXXXXX

Licensed features for this platform:
Maximum Physical Interfaces : Unlimited perpetual
Maximum VLANs : 100 perpetual
Inside Hosts : Unlimited perpetual
Failover : Active/Active perpetual
Encryption-DES : Enabled perpetual
Encryption-3DES-AES : Enabled perpetual
Security Contexts : 2 perpetual
GTP/GPRS : Disabled perpetual
AnyConnect Premium Peers : 2 perpetual
AnyConnect Essentials : Disabled perpetual
Other VPN Peers : 250 perpetual
Total VPN Peers : 250 perpetual
Shared License : Disabled perpetual
AnyConnect for Mobile : Disabled perpetual
AnyConnect for Cisco VPN Phone : Disabled perpetual
Advanced Endpoint Assessment : Disabled perpetual
UC Phone Proxy Sessions : 2 perpetual
Total UC Proxy Sessions : 2 perpetual
Botnet Traffic Filter : Disabled perpetual
Intercompany Media Engine : Disabled perpetual
Cluster : Disabled perpetual

This platform has an ASA 5510 Security Plus license.

 

The flash permanent activation key is the SAME as the running permanent key.
HT-HOMEASA#

Highlighted

That is correct, with the security plus license you can configure those two interfaces in Gig, however, that is the bandwidth not the throughput. This means that even if both inside and outside interfaces are in Gig, as in your case, the actual speed of processing and passing the traffic between the ingress and the egress interfaces is always subject to the device throughput. The device throughput depends on many factors, mainly it depends on the security features you enable, more you enable, less throughput you get. A huge impact on the throughput would be deep packet inspection and SSL decryption. Generally speaking the ASA devices have been always known with this caveat, however, it is a different story with Firepower appliances.

View solution in original post

Highlighted
VIP Mentor

Personally, I do not believe that model supports a maximum of 300MB, the thread mentioned only to use gigabit interface (not mentioned you get 1Gig throughput).

 

The 5510 only have functional 1Gbs ports if you enable the security plus license

 

correct me unless i am reading wrong...

BB
*** Rate All Helpful Responses ***

View solution in original post

Highlighted
Beginner

Thanks everyone for your assistance!! I have a more understanding my ASA now. 

Content for Community-Ad