cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

CSA 4.5 -> 5.2 migration

blwoltz
Beginner
Beginner

Anybody attempted to migrate CSAMC4.5 to new 5.2 on diff machines? I'm going through the install doc for this process, I'm at the step where I run prepare_45_migration.exe on my 4.5 server. I've disabled CSA on 4.5 server, and the exe looks to run fine, but I have no migration_data_export.xml in my export foler. I have all the migration_host_data<number>.dat files and migration.log, but not the xml file. Anybody have any ideas what I'm missing?

13 REPLIES 13

tsteger1
Collaborator
Collaborator

I migrated a 4.0.3 and a 5.1 box successfully (after a few hiccups).

On the 4.0.3 MC, I had to delete the migration and export folders and run it again becuase it did not finish completely (it didn't create the SW updates).

Try deleting everything and running it again and see what happens.

Tom

Thanks Tom, I deleted the folders and re-ran the migration exe and same thing happened. No .xml file in there.

What did the migration log show?

The beginning looked like this:

Begining Migration

CSAMC Bin directory is: C:\PROGRA~1\CSCOpx\CSAMC\bin

Copying CSAAgent-windows-MKV5.2.0.203.exe to C:\PROGRA~1\CSCOpx\CSAMC\bin\webserver\htdocs\Software_kits\CSAAgent-windows-MKV5.2.0.203.exe

Copying CSAAgent-sol-MKV5.2.0.203.tar to C:\PROGRA~1\CSCOpx\CSAMC\bin\webserver\htdocs\Software_kits\CSAAgent-sol-MKV5.2.0.203.tar

Copied necessary TCL files

C:\PROGRA~1\CSCOpx\CSAMC\bin\webmgr.exe export_migration_data C:\PROGRA~1\CSCOpx\CSAMC\migration\export\migration_data_export.xml

The last lines showed this:

Successfully registered the sofware upgrade information in the database

End of migration

Tom

My log says this......

CSAMC Bin directory is: d:\CW2000\CSAMC45\bin

Copying CSAAgent-windows-MKV5.2.0.203.exe to d:\CW2000\CSAMC45\bin\webserver\htdocs\Software_kits\CSAAgent-windows-MKV5.2.0.203.exe

Copying CSAAgent-sol-MKV5.2.0.203.tar to d:\CW2000\CSAMC45\bin\webserver\htdocs\Software_kits\CSAAgent-sol-MKV5.2.0.203.tar

Copying CSAAgent-lin-MKV5.2.0.203.tar to d:\CW2000\CSAMC45\bin\webserver\htdocs\Software_kits\CSAAgent-lin-MKV5.2.0.203.tar

Copied necessary TCL files

d:\CW2000\CSAMC45\bin\webmgr.exe export_migration_data d:\CW2000\CSAMC45\migration\export\migration_data_export.xml

I got the same results on a fresh 4.5 install. This is not what should happen.

I also got this in the Windows Application Event log:

Event Type: Information

Event Source: CSAgent

Event Category: Local Event Mgr

Event ID: 256

Date: 4/11/2007

Time: 12:21:21 PM

User: N/A

Computer: SERVER2000CLONE

Description:

[2007-04-11 12:21:21.078] [PID=4832] [WebMgr]: Error processing command line request:

I don't know what process PID 4832 is but it's spawned by the migration process and indicates a failure.

I suggest opening a TAC case.

Tom

Well, I installed a fresh 5.2 MC and ran the migration wizard on 4.0.3 and it failed just like yours.

The last line in the log is actually the command that creates the xml file.

If you execute:

"d:\CW2000\CSAMC45\bin\webmgr.exe export_migration_data d:\CW2000\CSAMC45\migration\export\migration_data_export.xml"

it will create the xml file but it doesn't finish the script and register the software updates afterward.

The script is failing and exiting before it is done.

I will probably open a TAC case tomorrow.

Tom

Thanks Tom, I actually have a TAC case opened as well. I'll post what I find out if you'll do the same with your TAC case.

TAC's response to my case.....

Hi Ben,

The migratation was tested in the Labs and we got the same results. My collaboration team asked me to escalate this ticket to the next level. A new engineer will contact you shortly.

Sorry for the inconvenience that it may cause.

Regards,

Thanks Ben, I guess we all got the same result and my failure, then success, then failure again was just a fluke.

I think one TAC case ought to do it unless I need to do a separate one for 4.0.X.

Hopefully they will issue an interim fix like a dosql statement in the meantime.

Tom

Hi Ben, there is a workaround here:

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCsi50901

It worked for me on 4.0.3-737 by running the prepare migration tool in a command window.

Tom

Thanks Tom, thats actually the bug they created when I contacted TAC and they gave me the same workaround. Mine still doesn't work, I get the below error. The cmd prompt goes through with the dots as if its going to work, but a min or two into it this errors comes up and breaks out of the export and no xml file still. TAC hasn't gotten back to me yet on why I'm getting this error.

.Error: Could not export agent kits, hosts, groups, alerts: {Could not find rul

e module info with id=136} {Could not find rule module info with id=126} {Could

not export items of type rule module info referenced by event set (id=20)} {Coul

d not export items of type event set referenced by alert (id=6)}

Weird, do those rules and event set not exist?

Also, did you try running

"d:\CW2000\CSAMC45\bin\webmgr.exe export_migration_data d:\CW2000\CSAMC45\migration\export\migration_data_export.xml" ?

It created the .xml file but won't register the software updates.

At least you can install an agent manually if you want to start testing.

You know, maybe it's a sign for you to start over fresh?

Tom

TAC just responded that they've created a new BugID for my issue (CSCsi57040). Its not posted online yet but will shortly, the description is below. I'm in process of doing the workaround now.

> Symptom:

> The CSA MC configuration migration from V4.5 to V5.2 fails.

>

> Conditions:

> - there is at least one alert configured with the V4.5 CSA MC;

> - the alert points to an event set referring to a deleted group or rule module;

>

> Workaround:

> Delete all the alerts configured with the V4.5 CSA MC before running the migration tool.

> Alternatively, the configuration of the event sets referenced by those alerts can be fixed so that only valid groups/modules are selected.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: