cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1435
Views
0
Helpful
6
Replies
laith_mig
Beginner

Firepower FPR 4100 FXOS upgrade Failure

Hi all;

I was trying to upgrade FXOS in Firepower chassis Manager (FPR4100) to 2.1.1.73 version, once the upgrade completed the chassis reloaded but unfortunately I lose communication with the chassis management port, When I've checked it through console, I found crashes logs, you can see these logs in attached file, it says that a corruptions happens in the filesystems, how can I fix this issue? is it could be related to a bug behavior?.

Thanks

2 ACCEPTED SOLUTIONS

Accepted Solutions
Karsten Iwen
VIP Mentor

Just a guess: Are you upgrading from an older release?Then you have to do some interim-steps:

http://www.cisco.com/c/en/us/td/docs/security/firepower/fxos/fxos211/release/notes/fxos211_rn.html#pgfId-141076

View solution in original post

Since you have not followed the required upgrade path and the device is now in a non-operational state, you should open a TAC case straight away for hands on assistance from a Cisco TAC engineer. The assigned engineer will help you to first revert to the earlier image and then upgrade per the required path to get to the current release.

View solution in original post

6 REPLIES 6
Karsten Iwen
VIP Mentor

Just a guess: Are you upgrading from an older release?Then you have to do some interim-steps:

http://www.cisco.com/c/en/us/td/docs/security/firepower/fxos/fxos211/release/notes/fxos211_rn.html#pgfId-141076

View solution in original post

thanks for reply, Yes I upgraded FX-OS from older version as you can see from table below:

firepower /firmware # show package
Name Version
--------------------------------------------- -------
fxos-k9.1.1.4.95.SPA 1.1(4.95)
fxos-k9.2.1.1.73.SPA 2.1(1.73)

the current version now as i think is 2.1(1.73),

but how can I fix the issue (let say downgrade the system to the older version)

Note: Management port is down, so could I downgrade the system to solve the issue from cli?

Since you have not followed the required upgrade path and the device is now in a non-operational state, you should open a TAC case straight away for hands on assistance from a Cisco TAC engineer. The assigned engineer will help you to first revert to the earlier image and then upgrade per the required path to get to the current release.

View solution in original post

Thanks for reply, I've connected to the chassis using console and try to revert back to the old image 1.1(4.95) using /firmware/auto-install # install platform platform-vers 1.1(4.95)

but I get the same crash logs, so the management port as well Fiber module is down.

By performing a cold boot for the chassis the issue has been SOLVED.

After that I did upgrade per required path and it was done successfully.

Thanks all for your valuable replies.

Having the same issue here.

 

Marvin are you saying that Cisco actually wants us to spend approx. 2,5 hours just to get FXOS from 1.1(4), to ex. 2.2(2)? as that requires 5 upgrades of around 30 minutes each? doesn't seem like time well spent.

If you need to move up from that earlier release unfortunately you need to follow the documented path.

 

I agree that it would be nice if that wasn't necessary, but this is a relatively new hardware platform and it's still going through growing pains.

Content for Community-Ad