cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

187
Views
0
Helpful
1
Replies
pedersen
Beginner

Giving Users on the Outside Interface access to the Internet trough the PIX

Hi,

A question, is it possible to give 3 network pleased on the Outside of a PIX Firewall access to the Internet trough the PIX fireall and into the Internet connection pleased on the inside of the PIX?

The problem is that if my 3 network needs to go access to the internal network i need to make a static for all the internal network in the PIX (static (inside,outside.....)

But i can't do a static on the 0.0.0.0 :)

Anyone got an idea? Or do i have to change the Networks on the PIX so outside becomes inside and the other way around?

Here is the configuration of the PIX

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx

passwd xxxx

hostname PIX506-Paprsek

domain-name fibertex.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list from-outside permit ip any any

access-list from-outside permit icmp any any

access-list from-inside permit ip any any

access-list from-inside permit icmp any any

pager lines 24

icmp permit any outside

icmp permit any inside

mtu outside 1500

mtu inside 1500

ip address outside 192.168.59.254 255.255.252.0

ip address inside 192.168.68.2 255.255.252.0

ip audit info action alarm

ip audit attack action alarm

arp timeout 14400

nat (outside) 0 0.0.0.0 0.0.0.0 0 0

nat (inside) 0 0.0.x.x.x.0.0 0 0

static (inside,outside) 172.x.x.x.17.0.0 netmask 255.255.0.0 0 0

static (inside,outside) 172.x.x.x.17.0.0 netmask 255.255.0.0 0 0

static (inside,outside) 10.x.x.x.0.0.0 netmask 255.255.0.0 0 0

static (inside,outside) 192.168.80.0 192.168.80.0 netmask 255.255.255.0 0 0

static (inside,outside) 192.168.90.0 192.168.90.0 netmask 255.255.255.0 0 0

static (inside,outside) 192.168.100.0 192.168.100.0 netmask 255.255.255.0 0 0

static (inside,outside) 192.168.200.0 192.168.200.0 netmask 255.255.255.0 0 0

access-group from-outside in interface outside

access-group from-inside in interface inside

router ospf 1

network 192.168.56.0 255.255.252.0 area 0

network 192.168.68.0 255.255.252.0 area 0

router-id 192.168.59.254

log-adj-changes

default-information originate always

route inside 0.0.0.0 0.0.0.0 192.168.68.1 200

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

ssh timeout 5

console timeout 0

terminal width 80

Best Regards,

Anders.

1 REPLY 1
owillins
Frequent Contributor

There are 2 ways to get traffic to pass from the outside to the inside - there is the static command as you mention but the problem you have is that the destination of the devices on the outside is somewhere on the internet so the destination has to be an "any" or 0.0.0.0 statement but the pix will not accept that in a static. The second method is nat 0 using an access list - this command bypasses nat in the pix but the result is very similar to using a static.

Create
Recognize Your Peers
Content for Community-Ad